summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch b/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch
new file mode 100644
index 0000000000..b090755f8a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch
@@ -0,0 +1,24 @@
1Upstream-Status: Submitted [https://github.com/danthedeckie/simpleeval/pull/119]
2Signed-off-by: Ross Burton <ross.burton@arm.com>
3
4From 08bc99211aec32882d5f1c83896eb5d72b9fb125 Mon Sep 17 00:00:00 2001
5From: Ross Burton <ross.burton@arm.com>
6Date: Mon, 23 May 2022 11:35:00 +0100
7Subject: [PATCH] pyproject.toml: remove build as a build-dependency
8
9pypa/build is one possible build tool, but not the only build tool. Forcing build to be present as a build dependency is meaningless: either the user is using build so obviously have build, or are using something else so having build is irrelevant.
10---
11 pyproject.toml | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/pyproject.toml b/pyproject.toml
15index 052a55a..416482b 100644
16--- a/pyproject.toml
17+++ b/pyproject.toml
18@@ -1,5 +1,5 @@
19 [build-system]
20-requires = ["setuptools>=30.3.0", "wheel", "build"]
21+requires = ["setuptools>=30.3.0", "wheel"]
22 build-backend = "setuptools.build_meta"
23
24 [tool.black]