summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-socketio_5.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-socketio_5.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-socketio_5.6.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-socketio_5.6.0.bb b/meta-python/recipes-devtools/python/python3-socketio_5.6.0.bb
new file mode 100644
index 0000000000..d762611487
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-socketio_5.6.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Socket.IO server"
2HOMEPAGE = "https://github.com/miguelgrinberg/python-socketio/"
3SECTION = "devel/python"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8"
7
8inherit pypi python_setuptools_build_meta
9
10PYPI_PACKAGE = "python-socketio"
11
12SRC_URI[sha256sum] = "f1f2eabdea500dbcb384902418cacedd98b7fe4d0fed818415ddf8af10e428fa"
13
14PACKAGECONFIG ?= "asyncio_client client"
15PACKAGECONFIG[asyncio_client] = ",,,${PYTHON_PN}-aiohttp ${PYTHON_PN}-websockets"
16PACKAGECONFIG[client] = ",,,${PYTHON_PN}-requests ${PYTHON_PN}-websocket-client"
17
18RDEPENDS:${PN} += "\
19 ${PYTHON_PN}-engineio \
20 ${PYTHON_PN}-logging \
21 ${PYTHON_PN}-math \
22 ${PYTHON_PN}-pickle \
23 ${PYTHON_PN}-json \
24 ${PYTHON_PN}-threading \
25 ${PYTHON_PN}-six \
26 ${PYTHON_PN}-attrs \
27 ${PYTHON_PN}-bidict \
28 "