summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlparse_0.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlparse_0.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlparse_0.5.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse_0.5.0.bb b/meta-python/recipes-devtools/python/python3-sqlparse_0.5.0.bb
new file mode 100644
index 0000000000..e10c97d772
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlparse_0.5.0.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Non-validating SQL parser module"
2HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
6
7SRC_URI:append = " \
8 file://run-ptest \
9"
10
11SRC_URI[sha256sum] = "714d0a4932c059d16189f58ef5411ec2287a4360f17cdd0edd2d09d4c5087c93"
12
13export BUILD_SYS
14export HOST_SYS
15
16inherit pypi ptest python_hatchling
17
18RDEPENDS:${PN}-ptest += "\
19 python3-pytest \
20 python3-unittest-automake-output \
21 python3-unixadmin \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
28
29BBCLASSEXTEND = "native nativesdk"