summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlparse_0.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlparse_0.5.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlparse_0.5.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse_0.5.2.bb b/meta-python/recipes-devtools/python/python3-sqlparse_0.5.2.bb
new file mode 100644
index 0000000000..a293b0bd96
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlparse_0.5.2.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Non-validating SQL parser module"
2HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
6
7SRC_URI:append = " \
8 file://run-ptest \
9"
10
11SRC_URI[sha256sum] = "9e37b35e16d1cc652a2545f0997c1deb23ea28fa1f3eefe609eee3063c3b105f"
12
13export BUILD_SYS
14export HOST_SYS
15
16inherit pypi ptest python_hatchling
17
18RDEPENDS:${PN}-ptest += "\
19 python3-mypy \
20 python3-pytest \
21 python3-unittest-automake-output \
22 python3-unixadmin \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}
29
30BBCLASSEXTEND = "native nativesdk"