summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.0.bb b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.0.bb
new file mode 100644
index 0000000000..4797a3535f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "A portable, lightweight MessagePack serializer and deserializer written in pure Python."
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9eb4691bcb66360acee473a8cf75f594"
5
6SRC_URI[md5sum] = "231609d87aa58459a1491c8f5df4e4cd"
7SRC_URI[sha256sum] = "996e4c4454771f0ff0fd2a7566b1a159d305d3611cd755addf444e3533e2bc54"
8
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 cp -f ${S}/test_umsgpack.py ${D}${PTEST_PATH}/
21}
22
23RDEPENDS_${PN} += " \
24 ${PYTHON_PN}-datetime \
25"
26
27BBCLASSEXTEND = "native nativesdk"