summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-api-python-client_2.10.0.bb20
-rw-r--r--meta-python/recipes-devtools/python/python3-google-api-python-client_2.6.0.bb9
2 files changed, 20 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-api-python-client_2.10.0.bb b/meta-python/recipes-devtools/python/python3-google-api-python-client_2.10.0.bb
new file mode 100644
index 0000000000..b406f677d8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-api-python-client_2.10.0.bb
@@ -0,0 +1,20 @@
1SUMMARY = "The Google API Client for Python is a client library for accessing the Plus, \
2Moderator, and many other Google APIs."
3HOMEPAGE = "https://github.com/googleapis/google-api-python-client"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=94023d14f6b58272fd885e4e3f2f08b3"
6
7SRC_URI[sha256sum] = "58424d263344625dcf4dc08e7639a6714737102ab4ae83e5f043e3db08d9965f"
8
9inherit pypi setuptools3
10
11RDEPENDS_${PN} += "\
12 ${PYTHON_PN}-logging \
13 ${PYTHON_PN}-six \
14 ${PYTHON_PN}-json \
15 ${PYTHON_PN}-core \
16 ${PYTHON_PN}-netclient \
17 ${PYTHON_PN}-httplib2 \
18 ${PYTHON_PN}-uritemplate \
19 ${PYTHON_PN}-google-api-core \
20"
diff --git a/meta-python/recipes-devtools/python/python3-google-api-python-client_2.6.0.bb b/meta-python/recipes-devtools/python/python3-google-api-python-client_2.6.0.bb
deleted file mode 100644
index c6ae6e8475..0000000000
--- a/meta-python/recipes-devtools/python/python3-google-api-python-client_2.6.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
1SUMMARY = "The Google API Client for Python is a client library for accessing the Plus, \
2Moderator, and many other Google APIs."
3HOMEPAGE = "https://github.com/googleapis/google-api-python-client"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=94023d14f6b58272fd885e4e3f2f08b3"
6
7SRC_URI[sha256sum] = "6a87f324334247bf7ba24406da586424b09e715d04336fb7cf45a402b80d38e8"
8
9inherit pypi setuptools3