diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-propcache/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-propcache_0.2.0.bb | 21 |
2 files changed, 21 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-propcache/run-ptest b/meta-python/recipes-devtools/python/python3-propcache/run-ptest new file mode 100644 index 0000000000..8d2017d39c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-propcache/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-propcache_0.2.0.bb b/meta-python/recipes-devtools/python/python3-propcache_0.2.0.bb index 874c9fd8ee..5f9fbda5f1 100644 --- a/meta-python/recipes-devtools/python/python3-propcache_0.2.0.bb +++ b/meta-python/recipes-devtools/python/python3-propcache_0.2.0.bb | |||
@@ -5,9 +5,24 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | |||
5 | 5 | ||
6 | SRC_URI[sha256sum] = "df81779732feb9d01e5d513fad0122efb3d53bbc75f61b2a4f29a020bc985e70" | 6 | SRC_URI[sha256sum] = "df81779732feb9d01e5d513fad0122efb3d53bbc75f61b2a4f29a020bc985e70" |
7 | 7 | ||
8 | inherit pypi python_setuptools_build_meta | 8 | inherit pypi python_setuptools_build_meta ptest |
9 | |||
10 | SRC_URI += " \ | ||
11 | file://run-ptest \ | ||
12 | " | ||
9 | 13 | ||
10 | DEPENDS += " \ | 14 | DEPENDS += " \ |
11 | python3-expandvars-native \ | 15 | python3-expandvars-native \ |
12 | python3-cython-native \ | 16 | python3-cython-native \ |
13 | " | 17 | " |
18 | |||
19 | RDEPENDS:${PN}-ptest = " \ | ||
20 | python3-pytest \ | ||
21 | python3-pytest-xdist \ | ||
22 | python3-unittest-automake-output \ | ||
23 | " | ||
24 | |||
25 | do_install_ptest() { | ||
26 | install -d ${D}${PTEST_PATH}/tests | ||
27 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
28 | } | ||