summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch29
-rw-r--r--meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb (renamed from meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb)3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch b/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch
new file mode 100644
index 0000000000..47da2b8cfc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch
@@ -0,0 +1,29 @@
1From aec3b64b0aaea0178b44ea65a204d76696e6a45e Mon Sep 17 00:00:00 2001
2From: Leon Anavi <leon.anavi@konsulko.com>
3Date: Mon, 10 Jan 2022 14:04:28 +0200
4Subject: [PATCH] setup.py: Do not strip debugging symbols
5
6Do not strip debugging symbols from Linux binaries to avoid
7bitbake build errors related to already-stripped.
8
9Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
10---
11 setup.py | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/setup.py b/setup.py
15index 453dc31..962c507 100644
16--- a/setup.py
17+++ b/setup.py
18@@ -6,7 +6,7 @@ from setuptools import Extension, setup
19 dconv_source_files = glob("./deps/double-conversion/double-conversion/*.cc")
20 dconv_source_files.append("./lib/dconv_wrapper.cc")
21
22-strip_flags = ["-Wl,--strip-all"] if platform.system() == "Linux" else []
23+strip_flags = []
24
25 module1 = Extension(
26 "ujson",
27--
282.30.2
29
diff --git a/meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb b/meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb
index fb1bcd7618..6c1bf7e82c 100644
--- a/meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb
@@ -4,12 +4,13 @@ DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pu
4LICENSE = "BSD-3-Clause" 4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe" 5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
6 6
7SRC_URI[sha256sum] = "3ff7242816b1d22c08c04c4c6db0f6ba7c16cd624ce38534c1025defa011e50e" 7SRC_URI[sha256sum] = "a88944d2f99db71a3ca0c63d81f37e55b660edde0b07216fb65a3e46403ef004"
8 8
9inherit pypi ptest setuptools3 9inherit pypi ptest setuptools3
10 10
11SRC_URI += " \ 11SRC_URI += " \
12 file://run-ptest \ 12 file://run-ptest \
13 file://0001-setup.py-Do-not-strip-debugging-symbols.patch \
13" 14"
14 15
15DEPENDS += "${PYTHON_PN}-setuptools-scm-native" 16DEPENDS += "${PYTHON_PN}-setuptools-scm-native"