summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-outcome/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-outcome_1.3.0.post0.bb26
2 files changed, 25 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-outcome/run-ptest b/meta-python/recipes-devtools/python/python3-outcome/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-outcome/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-outcome_1.3.0.post0.bb b/meta-python/recipes-devtools/python/python3-outcome_1.3.0.post0.bb
index 89c0da470e..9714301879 100644
--- a/meta-python/recipes-devtools/python/python3-outcome_1.3.0.post0.bb
+++ b/meta-python/recipes-devtools/python/python3-outcome_1.3.0.post0.bb
@@ -7,10 +7,28 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=fa7b86389e58dd4087a8d2b833e5fe96 \
7 7
8SRC_URI[sha256sum] = "9dcf02e65f2971b80047b377468e72a268e15c0af3cf1238e6ff14f7f91143b8" 8SRC_URI[sha256sum] = "9dcf02e65f2971b80047b377468e72a268e15c0af3cf1238e6ff14f7f91143b8"
9 9
10inherit pypi setuptools3 10inherit pypi setuptools3 ptest
11 11
12RDEPENDS:${PN} += "python3-attrs" 12SRC_URI += " \
13 file://run-ptest \
14"
13 15
14RDEPENDS:${PN} += "python3-asyncio python3-core python3-pytest python3-typing-extensions" 16RDEPENDS:${PN}-ptest += " \
17 python3-pytest \
18 python3-pytest-asyncio \
19 python3-unittest-automake-output \
20 python3-outcome \
21"
15 22
16PYPI_PACKAGE = "outcome" 23RDEPENDS:${PN} += " \
24 python3-asyncio \
25 python3-attrs \
26 python3-core \
27 python3-pytest \
28 python3-typing-extensions \
29"
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
34}