summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow/0001-support-cross-compiling.patch43
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_8.1.0.bb (renamed from meta-python/recipes-devtools/python/python3-pillow_7.2.0.bb)7
2 files changed, 16 insertions, 34 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow/0001-support-cross-compiling.patch b/meta-python/recipes-devtools/python/python3-pillow/0001-support-cross-compiling.patch
index 6de19ad87a..e4ba35b886 100644
--- a/meta-python/recipes-devtools/python/python3-pillow/0001-support-cross-compiling.patch
+++ b/meta-python/recipes-devtools/python/python3-pillow/0001-support-cross-compiling.patch
@@ -1,20 +1,21 @@
1From ae7c8d0336381dd4c10e809e9c8926f9deeafeb8 Mon Sep 17 00:00:00 2001 1From cd09b6f68aa49c72e9a9bb0765e8c666238a7b7e Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Leon Anavi <leon.anavi@konsulko.com>
3Date: Thu, 14 Mar 2019 03:48:10 -0400 3Date: Mon, 11 Jan 2021 13:25:12 +0000
4Subject: [PATCH] support cross compiling 4Subject: [PATCH] support cross compiling
5 5
6Upstream-Status: Inappropriate [oe specific] 6Upstream-Status: Inappropriate [oe specific]
7 7
8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> 8Suggested-by: Hongxu Jia <hongxu.jia@windriver.com>
9Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
9--- 10---
10 setup.py | 13 +++---------- 11 setup.py | 6 +++---
11 1 file changed, 3 insertions(+), 10 deletions(-) 12 1 file changed, 3 insertions(+), 3 deletions(-)
12 13
13diff --git a/setup.py b/setup.py 14diff --git a/setup.py b/setup.py
14index 5ceae344..07863340 100755 15index cbc2641c..302bc6e7 100755
15--- a/setup.py 16--- a/setup.py
16+++ b/setup.py 17+++ b/setup.py
17@@ -105,7 +105,7 @@ _LIB_IMAGING = ( 18@@ -123,7 +123,7 @@ _LIB_IMAGING = (
18 "codec_fd", 19 "codec_fd",
19 ) 20 )
20 21
@@ -23,39 +24,21 @@ index 5ceae344..07863340 100755
23 24
24 25
25 class DependencyException(Exception): 26 class DependencyException(Exception):
26@@ -396,21 +396,16 @@ class pil_build_ext(build_ext): 27@@ -408,12 +408,12 @@ class pil_build_ext(build_ext):
27 _add_directory(library_dirs, match.group(1)) 28 _add_directory(library_dirs, match.group(1))
28 29
29 # include, rpath, if set as environment variables: 30 # include, rpath, if set as environment variables:
30- for k in ("C_INCLUDE_PATH", "CPATH", "INCLUDE"): 31- for k in ("C_INCLUDE_PATH", "CPATH", "INCLUDE"):
31+ for k in ('C_INCLUDE_PATH', 'CPATH', 'INCLUDE', 'STAGING_INCDIR'): 32+ for k in ("C_INCLUDE_PATH", "CPATH", "INCLUDE", "STAGING_INCDIR"):
32 if k in os.environ: 33 if k in os.environ:
33 for d in os.environ[k].split(os.path.pathsep): 34 for d in os.environ[k].split(os.path.pathsep):
34 _add_directory(include_dirs, d) 35 _add_directory(include_dirs, d)
35 36
36- for k in ("LD_RUN_PATH", "LIBRARY_PATH", "LIB"): 37- for k in ("LD_RUN_PATH", "LIBRARY_PATH", "LIB"):
37+ for k in ('LD_RUN_PATH', 'LIBRARY_PATH', 'LIB', 'STAGING_LIBDIR'): 38+ for k in ("LD_RUN_PATH", "LIBRARY_PATH", "LIB", "STAGING_LIBDIR"):
38 if k in os.environ: 39 if k in os.environ:
39 for d in os.environ[k].split(os.path.pathsep): 40 for d in os.environ[k].split(os.path.pathsep):
40 _add_directory(library_dirs, d) 41 _add_directory(library_dirs, d)
41
42- prefix = sysconfig.get_config_var("prefix")
43- if prefix:
44- _add_directory(library_dirs, os.path.join(prefix, "lib"))
45- _add_directory(include_dirs, os.path.join(prefix, "include"))
46-
47 #
48 # add platform directories
49
50@@ -469,8 +464,6 @@ class pil_build_ext(build_ext):
51 or sys.platform.startswith("gnu")
52 or sys.platform.startswith("freebsd")
53 ):
54- for dirname in _find_library_dirs_ldconfig():
55- _add_directory(library_dirs, dirname)
56 if sys.platform.startswith("linux") and os.environ.get(
57 "ANDROID_ROOT", None
58 ):
59-- 42--
602.20.1 432.17.1
61 44
diff --git a/meta-python/recipes-devtools/python/python3-pillow_7.2.0.bb b/meta-python/recipes-devtools/python/python3-pillow_8.1.0.bb
index 13cab43008..63974590cc 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_7.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_8.1.0.bb
@@ -3,14 +3,13 @@ Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
3Contributors." 3Contributors."
4HOMEPAGE = "https://pillow.readthedocs.io" 4HOMEPAGE = "https://pillow.readthedocs.io"
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ea2dc3f5611e69058503d4b940049d03" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=0337b116233da4616ae9fdb130bf6f1a"
7 7
8SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=7.2.x \ 8SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=8.1.x \
9 file://0001-support-cross-compiling.patch \ 9 file://0001-support-cross-compiling.patch \
10 file://0001-explicitly-set-compile-options.patch \ 10 file://0001-explicitly-set-compile-options.patch \
11" 11"
12SRCREV ?= "2bd74943fb9f320def6c066e732b701d1c15f677" 12SRCREV ?= "fcc42e0d344146ee9d265d1f43c094ce5a0ec4cf"
13
14 13
15inherit setuptools3 14inherit setuptools3
16 15