summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-meh
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-meh')
-rw-r--r--meta-python/recipes-extended/python-meh/files/tweak-native-language-support.patch44
-rw-r--r--meta-python/recipes-extended/python-meh/python3-meh_0.45.bb17
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-meh/files/tweak-native-language-support.patch b/meta-python/recipes-extended/python-meh/files/tweak-native-language-support.patch
new file mode 100644
index 0000000000..41cfaddc9e
--- /dev/null
+++ b/meta-python/recipes-extended/python-meh/files/tweak-native-language-support.patch
@@ -0,0 +1,44 @@
1From 6e7689bced8ef56cfb5969560d23706f8e039807 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Mon, 11 Apr 2016 23:01:19 -0400
4Subject: [PATCH] tweak native language support
5
6- Only support en_GB only.
7
8Upstream-Status: Inappropriate [oe specific]
9
10Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
11---
12 Makefile | 9 ++++++++-
13 1 file changed, 8 insertions(+), 1 deletion(-)
14
15diff --git a/Makefile b/Makefile
16index d0a9784..db152c4 100644
17--- a/Makefile
18+++ b/Makefile
19@@ -24,7 +24,7 @@ test:
20 PYTHONPATH=. python $(TESTSUITE) -v
21
22 install:
23- python setup.py install --root=$(DESTDIR)
24+ python setup.py install --root=$(DESTDIR) --install-lib=${PYTHON_SITEPACKAGES_DIR} --prefix=${prefix}
25 $(MAKE) -C po install
26
27 ChangeLog:
28@@ -61,6 +61,13 @@ rpmlog:
29 @git log --pretty="format:- %s (%ae)" $(TAG).. |sed -e 's/@.*)/)/'
30 @echo
31
32+po-empty:
33+ for lingua in "en_GB" ; do \
34+ [ -f po/$$lingua.po ] || \
35+ msginit -i po/$(PKGNAME).pot -o po/$$lingua.po -l $$lingua --no-translator || \
36+ exit 1 ; \
37+ done
38+
39 potfile:
40 $(MAKE) -C po potfile
41
42--
431.9.1
44
diff --git a/meta-python/recipes-extended/python-meh/python3-meh_0.45.bb b/meta-python/recipes-extended/python-meh/python3-meh_0.45.bb
new file mode 100644
index 0000000000..6ace497811
--- /dev/null
+++ b/meta-python/recipes-extended/python-meh/python3-meh_0.45.bb
@@ -0,0 +1,17 @@
1SUMMARY = "A python library for handling exceptions"
2DESCRIPTION = "The python-meh package is a python library for handling, saving, and reporting \
3exceptions."
4HOMEPAGE = "http://git.fedorahosted.org/git/?p=python-meh.git"
5LICENSE = "GPLv2+"
6
7inherit setuptools3
8
9S = "${WORKDIR}/git"
10
11SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=master \
12"
13SRCREV = "2bfc751fd680515d44f7096945a1e282a1f7d6aa"
14LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
15
16FILES_${PN} += "${datadir}/*"
17