summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python/python-zopeinterface_4.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-python/python/python-zopeinterface_4.1.1.bb')
-rw-r--r--meta-python/recipes-python/python/python-zopeinterface_4.1.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-zopeinterface_4.1.1.bb b/meta-python/recipes-python/python/python-zopeinterface_4.1.1.bb
new file mode 100644
index 0000000000..4151f585b8
--- /dev/null
+++ b/meta-python/recipes-python/python/python-zopeinterface_4.1.1.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Interface definitions for Zope products"
2SECTION = "console/network"
3
4LICENSE = "ZPL-2.1"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e54fd776274c1b7423ec128974bd9d46"
6
7SRC_URI = "http://pypi.python.org/packages/source/z/zope.interface/zope.interface-${PV}.tar.gz"
8SRC_URI[md5sum] = "edcd5f719c5eb2e18894c4d06e29b6c6"
9SRC_URI[sha256sum] = "91cba7b7cd7cb82f6f4e023fe77f94dc3df4ae5287fd55def2148dc232d0c7da"
10
11S = "${WORKDIR}/zope.interface-${PV}"
12
13inherit setuptools
14
15RPROVIDES_${PN} += "zope-interfaces"
16FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug"
17FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c"
18FILES_${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt"
19FILES_${PN}-tests = " \
20 ${PYTHON_SITEPACKAGES_DIR}/zope/interface/tests \
21 ${PYTHON_SITEPACKAGES_DIR}/zope/interface/common/tests \
22"