summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-precise-runner/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb15
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-precise-runner/run-ptest b/meta-python/recipes-devtools/python/python3-precise-runner/run-ptest
new file mode 100644
index 0000000000..5cec711696
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-precise-runner/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest
diff --git a/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb b/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb
index 98b62d899c..6155b79818 100644
--- a/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb
@@ -6,4 +6,17 @@ LIC_FILES_CHKSUM = "file://README.md;md5=2ad29e930f3107d52d2a55728bf62116"
6SRC_URI[md5sum] = "a2434be110444192e804f4dada0ccecf" 6SRC_URI[md5sum] = "a2434be110444192e804f4dada0ccecf"
7SRC_URI[sha256sum] = "1a464209fb4bf0a3f5d5a428310cb2a70487a01a6bc3a960d1dda90af896b80d" 7SRC_URI[sha256sum] = "1a464209fb4bf0a3f5d5a428310cb2a70487a01a6bc3a960d1dda90af896b80d"
8 8
9inherit pypi setuptools3 9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/test
21 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
22}