summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-flask-migrate.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-migrate_2.5.2.bb16
2 files changed, 15 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-migrate.inc b/meta-python/recipes-devtools/python/python-flask-migrate.inc
deleted file mode 100644
index 5202f8be08..0000000000
--- a/meta-python/recipes-devtools/python/python-flask-migrate.inc
+++ /dev/null
@@ -1,14 +0,0 @@
1DESCRIPTION = "SQLAlchemy database migrations for Flask applications using Alembic"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=3b69377f79f3f48c661701236d5a6a85"
4
5SRC_URI[md5sum] = "bedeb0366740fda6912fea683be11968"
6SRC_URI[sha256sum] = "a96ff1875a49a40bd3e8ac04fce73fdb0870b9211e6168608cbafa4eb839d502"
7
8PYPI_PACKAGE = "Flask-Migrate"
9
10RDEPENDS_${PN} += "\
11 ${PYTHON_PN}-flask-sqlalchemy \
12 ${PYTHON_PN}-alembic \
13 ${PYTHON_PN}-flask \
14 "
diff --git a/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.2.bb b/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.2.bb
index c98cbfddb0..78ec665ef7 100644
--- a/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.2.bb
@@ -1,2 +1,16 @@
1DESCRIPTION = "SQLAlchemy database migrations for Flask applications using Alembic"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=3b69377f79f3f48c661701236d5a6a85"
4
5SRC_URI[md5sum] = "bedeb0366740fda6912fea683be11968"
6SRC_URI[sha256sum] = "a96ff1875a49a40bd3e8ac04fce73fdb0870b9211e6168608cbafa4eb839d502"
7
8PYPI_PACKAGE = "Flask-Migrate"
9
1inherit pypi setuptools3 10inherit pypi setuptools3
2require python-flask-migrate.inc 11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-flask-sqlalchemy \
14 ${PYTHON_PN}-alembic \
15 ${PYTHON_PN}-flask \
16 "