summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-ndg-httpsclient.inc25
-rw-r--r--meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb27
2 files changed, 26 insertions, 26 deletions
diff --git a/meta-python/recipes-devtools/python/python-ndg-httpsclient.inc b/meta-python/recipes-devtools/python/python-ndg-httpsclient.inc
deleted file mode 100644
index bca58f7646..0000000000
--- a/meta-python/recipes-devtools/python/python-ndg-httpsclient.inc
+++ /dev/null
@@ -1,25 +0,0 @@
1DESCRIPTION = "Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
2HOMEPAGE = "http://python-requests.org"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://MANIFEST.in;md5=ce22c0cd986d2de3f7073cd6b5523ae0"
5
6SRC_URI[md5sum] = "b0fc8ea38f87d2c1ab1ed79a95c078f9"
7SRC_URI[sha256sum] = "d72faed0376ab039736c2ba12e30695e2788c4aa569c9c3e3d72131de2592210"
8
9PYPI_PACKAGE = "ndg_httpsclient"
10
11DEPENDS += " \
12 ${PYTHON_PN}-pyopenssl \
13 ${PYTHON_PN}-pyasn1 \
14"
15
16RDEPENDS_${PN} += " \
17 ${PYTHON_PN}-datetime \
18 ${PYTHON_PN}-logging \
19 ${PYTHON_PN}-pyopenssl \
20 ${PYTHON_PN}-pyasn1 \
21"
22
23BBCLASSEXTEND = "native nativesdk"
24
25UPSTREAM_CHECK_REGEX = ""
diff --git a/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb b/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
index 65a8c816f4..23e1868c22 100644
--- a/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
@@ -1,5 +1,30 @@
1DESCRIPTION = "Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
2HOMEPAGE = "https://github.com/cedadev/ndg_httpsclient/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://MANIFEST.in;md5=ce22c0cd986d2de3f7073cd6b5523ae0"
5
6SRC_URI[md5sum] = "b0fc8ea38f87d2c1ab1ed79a95c078f9"
7SRC_URI[sha256sum] = "d72faed0376ab039736c2ba12e30695e2788c4aa569c9c3e3d72131de2592210"
8
1inherit pypi setuptools3 update-alternatives 9inherit pypi setuptools3 update-alternatives
2require python-ndg-httpsclient.inc 10
11PYPI_PACKAGE = "ndg_httpsclient"
12
13DEPENDS += " \
14 ${PYTHON_PN}-pyopenssl \
15 ${PYTHON_PN}-pyasn1 \
16"
17
18RDEPENDS_${PN} += " \
19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-logging \
21 ${PYTHON_PN}-pyopenssl \
22 ${PYTHON_PN}-pyasn1 \
23"
24
25BBCLASSEXTEND = "native nativesdk"
26
27UPSTREAM_CHECK_REGEX = ""
3 28
4ALTERNATIVE_${PN} = "ndg_httpclient" 29ALTERNATIVE_${PN} = "ndg_httpclient"
5ALTERNATIVE_LINK_NAME[ndg_httpclient] = "${bindir}/ndg_httpclient" 30ALTERNATIVE_LINK_NAME[ndg_httpclient] = "${bindir}/ndg_httpclient"