summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb18
-rw-r--r--meta-python/recipes-devtools/python/python-docutils_0.15.2.bb15
-rw-r--r--meta-python/recipes-devtools/python/python3-docutils_0.15.2.bb15
4 files changed, 31 insertions, 19 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 42f416346d..bb05de1f55 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -77,7 +77,7 @@ RDEPENDS_packagegroup-meta-python3 = "\
77 python3-pint python3-coverage python3-iso8601 python3-ndg-httpsclient python3-yappi python3-twofish \ 77 python3-pint python3-coverage python3-iso8601 python3-ndg-httpsclient python3-yappi python3-twofish \
78 python3-speaklater python3-smbus python3-djangorestframework python3-msgpack python3-jsonpointer \ 78 python3-speaklater python3-smbus python3-djangorestframework python3-msgpack python3-jsonpointer \
79 python3-flask-script python3-cassandra-driver python3-cython python3-ujson python3-aws-iot-device-sdk-python \ 79 python3-flask-script python3-cassandra-driver python3-cython python3-ujson python3-aws-iot-device-sdk-python \
80 python3-pytest-runner python3-pyiface python3-flask-login python3-markupsafe python3-setuptools-scm \ 80 python3-pytest-runner python3-pyiface python3-docutils python3-flask-login python3-markupsafe python3-setuptools-scm \
81 python3-semver python3-sdnotify python3-flask-user python3-tornado python3-jsonpatch python3-pexpect \ 81 python3-semver python3-sdnotify python3-flask-user python3-tornado python3-jsonpatch python3-pexpect \
82 python3-progress python3-jsonschema python3-xstatic python3-pyroute2 python3-idna python3-sqlalchemy \ 82 python3-progress python3-jsonschema python3-xstatic python3-pyroute2 python3-idna python3-sqlalchemy \
83 python3-urllib3 python3-flask-mail python3-asn1crypto python3-pyinotify python3-intervals python3-pyperclip \ 83 python3-urllib3 python3-flask-mail python3-asn1crypto python3-pyinotify python3-intervals python3-pyperclip \
diff --git a/meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb b/meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb
deleted file mode 100644
index 68436a1a54..0000000000
--- a/meta-python/recipes-devtools/python/python-docutils_0.14rc2.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1SUMMARY = "Text processing system for documentation"
2HOMEPAGE = "http://docutils.sourceforge.net"
3SECTION = "devel/python"
4LICENSE = "PSF & BSD-2-Clause & GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=35a23d42b615470583563132872c97d6"
6
7DEPENDS = "python"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/docutils/docutils-${PV}.tar.gz"
10SRC_URI[md5sum] = "2f4bee6451958252f7bec71f18b05be3"
11SRC_URI[sha256sum] = "3caee0bcb2a49fdf24fcfa70849a60abb7a181aa68b030f7cb7494096181830c"
12
13S = "${WORKDIR}/docutils-${PV}"
14
15inherit distutils
16
17BBCLASSEXTEND = "native"
18
diff --git a/meta-python/recipes-devtools/python/python-docutils_0.15.2.bb b/meta-python/recipes-devtools/python/python-docutils_0.15.2.bb
new file mode 100644
index 0000000000..d26e81908b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-docutils_0.15.2.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Text processing system for documentation"
2HOMEPAGE = "http://docutils.sourceforge.net"
3SECTION = "devel/python"
4LICENSE = "PSF & BSD-2-Clause & GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=7a4646907ab9083c826280b19e103106"
6
7inherit pypi setuptools
8
9PYPI_PACKAGE = "docutils"
10
11SRC_URI[md5sum] = "e26a308d8000b0bed7416a633217c676"
12SRC_URI[sha256sum] = "a2aeea129088da402665e92e0b25b04b073c04b2dce4ab65caaa38b7ce2e1a99"
13
14BBCLASSEXTEND = "native"
15
diff --git a/meta-python/recipes-devtools/python/python3-docutils_0.15.2.bb b/meta-python/recipes-devtools/python/python3-docutils_0.15.2.bb
new file mode 100644
index 0000000000..321f55572f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-docutils_0.15.2.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Text processing system for documentation"
2HOMEPAGE = "http://docutils.sourceforge.net"
3SECTION = "devel/python"
4LICENSE = "PSF & BSD-2-Clause & GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=7a4646907ab9083c826280b19e103106"
6
7inherit pypi setuptools3
8
9PYPI_PACKAGE = "docutils"
10
11SRC_URI[md5sum] = "e26a308d8000b0bed7416a633217c676"
12SRC_URI[sha256sum] = "a2aeea129088da402665e92e0b25b04b073c04b2dce4ab65caaa38b7ce2e1a99"
13
14BBCLASSEXTEND = "native"
15