diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch | 30 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb | 1 |
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch new file mode 100644 index 0000000000..da95ee7af5 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From b5d5a7efc7aaa2be830731001ed17c5b71bcefb1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mingli Yu <mingli.yu@windriver.com> | ||
3 | Date: Fri, 29 Jan 2021 02:33:06 +0000 | ||
4 | Subject: [PATCH] setup_build.py: avoid absolute path | ||
5 | |||
6 | Prevent absolute path from ending up in the egg-info SOURCES.txt. | ||
7 | |||
8 | Upstream-Status: Submitted [https://github.com/h5py/h5py/pull/1803] | ||
9 | |||
10 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
11 | --- | ||
12 | setup_build.py | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/setup_build.py b/setup_build.py | ||
16 | index ffd3bef..fb196c0 100644 | ||
17 | --- a/setup_build.py | ||
18 | +++ b/setup_build.py | ||
19 | @@ -20,7 +20,7 @@ import api_gen | ||
20 | |||
21 | |||
22 | def localpath(*args): | ||
23 | - return op.abspath(op.join(op.dirname(__file__), *args)) | ||
24 | + return op.join(*args) | ||
25 | |||
26 | |||
27 | MODULES = ['defs','_errors','_objects','_proxy', 'h5fd', 'h5z', | ||
28 | -- | ||
29 | 2.29.2 | ||
30 | |||
diff --git a/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb b/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb index 3904abbb48..b812b323fa 100644 --- a/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb +++ b/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb | |||
@@ -9,6 +9,7 @@ SRC_URI[sha256sum] = "84412798925dc870ffd7107f045d7659e60f5d46d1c70c700375248bf6 | |||
9 | 9 | ||
10 | SRC_URI_append = " \ | 10 | SRC_URI_append = " \ |
11 | file://0001-cross-compiling-support.patch \ | 11 | file://0001-cross-compiling-support.patch \ |
12 | file://0001-setup_build.py-avoid-absolute-path.patch \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | inherit pypi setuptools3 | 15 | inherit pypi setuptools3 |