summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-runner.inc16
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb18
2 files changed, 16 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest-runner.inc b/meta-python/recipes-devtools/python/python-pytest-runner.inc
deleted file mode 100644
index 0b443b3d61..0000000000
--- a/meta-python/recipes-devtools/python/python-pytest-runner.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1SUMMARY = "Invoke py.test as distutils command with dependency resolution"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
4
5SRC_URI[md5sum] = "e5f66b8e8e87f62c59631c35c919d321"
6SRC_URI[sha256sum] = "96c7e73ead7b93e388c5d614770d2bae6526efd997757d3543fe17b557a0942b"
7
8inherit pypi
9
10DEPENDS += " \
11 ${PYTHON_PN}-setuptools-scm-native"
12
13RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
14 ${PYTHON_PN}-io"
15
16BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb b/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
index df56ba6d47..d00cd48739 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
@@ -1,2 +1,16 @@
1inherit setuptools3 1SUMMARY = "Invoke py.test as distutils command with dependency resolution"
2require python-pytest-runner.inc 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
4
5SRC_URI[md5sum] = "e5f66b8e8e87f62c59631c35c919d321"
6SRC_URI[sha256sum] = "96c7e73ead7b93e388c5d614770d2bae6526efd997757d3543fe17b557a0942b"
7
8inherit pypi setuptools3
9
10DEPENDS += " \
11 ${PYTHON_PN}-setuptools-scm-native"
12
13RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
14 ${PYTHON_PN}-io"
15
16BBCLASSEXTEND = "native nativesdk"