summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-blinker/0001-use-pytest-instead-of-deprecated-nose.patch36
-rw-r--r--meta-python/recipes-devtools/python/python3-blinker_1.4.bb22
-rw-r--r--meta-python/recipes-devtools/python/python3-blinker_1.5.bb18
3 files changed, 18 insertions, 58 deletions
diff --git a/meta-python/recipes-devtools/python/python3-blinker/0001-use-pytest-instead-of-deprecated-nose.patch b/meta-python/recipes-devtools/python/python3-blinker/0001-use-pytest-instead-of-deprecated-nose.patch
deleted file mode 100644
index a04c79b1e0..0000000000
--- a/meta-python/recipes-devtools/python/python3-blinker/0001-use-pytest-instead-of-deprecated-nose.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From 9750d01118ee59ab174525e30d987065b69c0538 Mon Sep 17 00:00:00 2001
2From: pgajdos <pgajdos@suse.cz>
3Date: Wed, 8 Jul 2020 15:22:19 +0200
4Subject: [PATCH] use pytest instead of deprecated nose
5
6Upstream-Status: Submitted [https://github.com/jek/blinker/pull/60]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 tests/test_signals.py | 4 ++--
10 1 file changed, 2 insertions(+), 2 deletions(-)
11
12diff --git a/tests/test_signals.py b/tests/test_signals.py
13index 9771e40..ccbc35b 100644
14--- a/tests/test_signals.py
15+++ b/tests/test_signals.py
16@@ -4,7 +4,7 @@ import time
17
18 import blinker
19
20-from nose.tools import assert_raises
21+import pytest
22
23
24 jython = sys.platform.startswith('java')
25@@ -232,7 +232,7 @@ def test_meta_connect_failure():
26 pass
27 sig = blinker.Signal()
28
29- assert_raises(TypeError, sig.connect, receiver)
30+ pytest.raises(TypeError, sig.connect, receiver)
31 assert not sig.receivers
32 assert not sig._by_receiver
33 assert sig._by_sender == {blinker.base.ANY_ID: set()}
34--
352.35.1
36
diff --git a/meta-python/recipes-devtools/python/python3-blinker_1.4.bb b/meta-python/recipes-devtools/python/python3-blinker_1.4.bb
deleted file mode 100644
index 08a961f938..0000000000
--- a/meta-python/recipes-devtools/python/python3-blinker_1.4.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1DESCRIPTION = "Fast, simple object-to-object and broadcast signaling."
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=946d7e89af6f7733aeaebed5635d2682"
4
5SRC_URI[md5sum] = "8b3722381f83c2813c52de3016b68d33"
6SRC_URI[sha256sum] = "471aee25f3992bd325afa3772f1063dbdbbca947a041b8b89466dc00d606f8b6"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://0001-use-pytest-instead-of-deprecated-nose.patch \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
diff --git a/meta-python/recipes-devtools/python/python3-blinker_1.5.bb b/meta-python/recipes-devtools/python/python3-blinker_1.5.bb
new file mode 100644
index 0000000000..dae1e39437
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-blinker_1.5.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "Fast, simple object-to-object and broadcast signaling."
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=42cd19c88fc13d1307a4efd64ee90e4e"
4
5SRC_URI[sha256sum] = "923e5e2f69c155f2cc42dafbbd70e16e3fde24d2d4aa2ab72fbe386238892462"
6
7inherit pypi setuptools3 ptest
8
9SRC_URI += "file://run-ptest"
10
11RDEPENDS:${PN}-ptest += " \
12 ${PYTHON_PN}-pytest \
13"
14
15do_install_ptest() {
16 install -d ${D}${PTEST_PATH}/tests
17 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
18}