diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pymodbus_2.5.3.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymodbus_2.5.3.bb b/meta-python/recipes-devtools/python/python3-pymodbus_2.5.3.bb new file mode 100644 index 0000000000..b628cadafe --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pymodbus_2.5.3.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "A fully featured modbus protocol stack in python" | ||
2 | HOMEPAGE = "https://github.com/riptideio/pymodbus/" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2c2223d66c7e674b40527b5a4c35bd76" | ||
5 | DEPENDS += "python3-six-native" | ||
6 | |||
7 | SRC_URI[sha256sum] = "5ef68c1a109bdb467c830ef003ef2db6494349a5248e4af946fe21c9eefe7e74" | ||
8 | S = "${WORKDIR}/pymodbus-${PV}" | ||
9 | |||
10 | inherit pypi setuptools3 | ||
11 | |||
12 | PACKAGECONFIG ??= "" | ||
13 | PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio" | ||
14 | PACKAGECONFIG[tornado] = ",,,python3-tornado" | ||
15 | PACKAGECONFIG[twisted] = ",,,python3-twisted-conch" | ||
16 | PACKAGECONFIG[redis] = ",,,python3-redis" | ||
17 | PACKAGECONFIG[sql] = ",,,python3-sqlalchemy" | ||
18 | |||
19 | RDEPENDS:${PN} += " \ | ||
20 | python3-asyncio \ | ||
21 | python3-core \ | ||
22 | python3-io \ | ||
23 | python3-json \ | ||
24 | python3-logging \ | ||
25 | python3-math \ | ||
26 | python3-netserver \ | ||
27 | " | ||
28 | |||
29 | RDEPENDS:${PN} += " \ | ||
30 | python3-pyserial \ | ||
31 | python3-six \ | ||
32 | " | ||
33 | |||
34 | |||