diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pytoml/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb | 15 |
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytoml/run-ptest b/meta-python/recipes-devtools/python/python3-pytoml/run-ptest new file mode 100644 index 0000000000..5cec711696 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pytoml/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb b/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb index f8c759a7d4..b09005ec9e 100644 --- a/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb +++ b/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb | |||
@@ -7,6 +7,19 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=cfff423699bdaef24331933ac4f56078" | |||
7 | SRC_URI[md5sum] = "e59dd36a559dd2a876e4c149c69e947b" | 7 | SRC_URI[md5sum] = "e59dd36a559dd2a876e4c149c69e947b" |
8 | SRC_URI[sha256sum] = "8eecf7c8d0adcff3b375b09fe403407aa9b645c499e5ab8cac670ac4a35f61e7" | 8 | SRC_URI[sha256sum] = "8eecf7c8d0adcff3b375b09fe403407aa9b645c499e5ab8cac670ac4a35f61e7" |
9 | 9 | ||
10 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 ptest |
11 | 11 | ||
12 | BBCLASSEXTEND = "native nativesdk" | 12 | BBCLASSEXTEND = "native nativesdk" |
13 | |||
14 | SRC_URI += " \ | ||
15 | file://run-ptest \ | ||
16 | " | ||
17 | |||
18 | RDEPENDS_${PN}-ptest += " \ | ||
19 | ${PYTHON_PN}-pytest \ | ||
20 | " | ||
21 | |||
22 | do_install_ptest() { | ||
23 | install -d ${D}${PTEST_PATH}/test | ||
24 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/ | ||
25 | } | ||