diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-strip-binaries.patch | 52 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb | 5 |
2 files changed, 56 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-strip-binaries.patch b/meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-strip-binaries.patch new file mode 100644 index 0000000000..37cb78a308 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-strip-binaries.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | From debd676cd94f92a30b3be45f1245aa13d8c398c0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Philip Balister <philip@balister.org> | ||
3 | Date: Wed, 8 Jul 2020 09:41:43 -0400 | ||
4 | Subject: [PATCH] Do not strip binaries. | ||
5 | |||
6 | * OpenEmbedded strips them after creating debug packages. | ||
7 | |||
8 | Signed-off-by: Philip Balister <philip@balister.org> | ||
9 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
10 | --- | ||
11 | tools/pybind11NewTools.cmake | 7 ------- | ||
12 | tools/pybind11Tools.cmake | 6 ------ | ||
13 | 2 files changed, 13 deletions(-) | ||
14 | |||
15 | diff --git a/tools/pybind11NewTools.cmake b/tools/pybind11NewTools.cmake | ||
16 | index 7d7424a7..accd90c4 100644 | ||
17 | --- a/tools/pybind11NewTools.cmake | ||
18 | +++ b/tools/pybind11NewTools.cmake | ||
19 | @@ -233,13 +233,6 @@ function(pybind11_add_module target_name) | ||
20 | endif() | ||
21 | endif() | ||
22 | |||
23 | - # Use case-insensitive comparison to match the result of $<CONFIG:cfgs> | ||
24 | - string(TOUPPER "${CMAKE_BUILD_TYPE}" uppercase_CMAKE_BUILD_TYPE) | ||
25 | - if(NOT MSVC AND NOT "${uppercase_CMAKE_BUILD_TYPE}" MATCHES DEBUG|RELWITHDEBINFO) | ||
26 | - # Strip unnecessary sections of the binary on Linux/macOS | ||
27 | - pybind11_strip(${target_name}) | ||
28 | - endif() | ||
29 | - | ||
30 | if(MSVC) | ||
31 | target_link_libraries(${target_name} PRIVATE pybind11::windows_extras) | ||
32 | endif() | ||
33 | diff --git a/tools/pybind11Tools.cmake b/tools/pybind11Tools.cmake | ||
34 | index 66ad00a4..855ede41 100644 | ||
35 | --- a/tools/pybind11Tools.cmake | ||
36 | +++ b/tools/pybind11Tools.cmake | ||
37 | @@ -212,12 +212,6 @@ function(pybind11_add_module target_name) | ||
38 | endif() | ||
39 | endif() | ||
40 | |||
41 | - # Use case-insensitive comparison to match the result of $<CONFIG:cfgs> | ||
42 | - string(TOUPPER "${CMAKE_BUILD_TYPE}" uppercase_CMAKE_BUILD_TYPE) | ||
43 | - if(NOT MSVC AND NOT "${uppercase_CMAKE_BUILD_TYPE}" MATCHES DEBUG|RELWITHDEBINFO) | ||
44 | - pybind11_strip(${target_name}) | ||
45 | - endif() | ||
46 | - | ||
47 | if(MSVC) | ||
48 | target_link_libraries(${target_name} PRIVATE pybind11::windows_extras) | ||
49 | endif() | ||
50 | -- | ||
51 | 2.39.2 | ||
52 | |||
diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb index 13f63b7c62..78662fe3cd 100644 --- a/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb +++ b/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb | |||
@@ -8,7 +8,10 @@ DEPENDS = "\ | |||
8 | " | 8 | " |
9 | 9 | ||
10 | SRCREV = "8a099e44b3d5f85b20f05828d919d2332a8de841" | 10 | SRCREV = "8a099e44b3d5f85b20f05828d919d2332a8de841" |
11 | SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https" | 11 | SRC_URI = "\ |
12 | git://github.com/pybind/pybind11.git;branch=stable;protocol=https \ | ||
13 | file://0001-Do-not-strip-binaries.patch \ | ||
14 | " | ||
12 | 15 | ||
13 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
14 | 17 | ||