diff options
Diffstat (limited to 'meta-python')
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pydantic-core/0001-Fix-generate_self_schema-for-Python-3.12-1299.patch b/meta-python/recipes-devtools/python/python3-pydantic-core/0001-Fix-generate_self_schema-for-Python-3.12-1299.patch new file mode 100644 index 0000000000..f6aa18e303 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pydantic-core/0001-Fix-generate_self_schema-for-Python-3.12-1299.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 0dcca2ed6a83ebbc944ec8cbd2f67ffec8043461 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jelle Zijlstra <jelle.zijlstra@gmail.com> | ||
3 | Date: Wed, 22 May 2024 07:44:10 -0700 | ||
4 | Subject: [PATCH] Fix generate_self_schema for Python 3.12+ (#1299) | ||
5 | |||
6 | Upstream-Status: Backport [https://github.com/pydantic/pydantic-core/commit/a7620419383a69bd2b28ab953c9a17f6ed35bb9a] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | generate_self_schema.py | 7 ++++++- | ||
10 | 1 file changed, 6 insertions(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/generate_self_schema.py b/generate_self_schema.py | ||
13 | index 8d27247..109fca0 100644 | ||
14 | --- a/generate_self_schema.py | ||
15 | +++ b/generate_self_schema.py | ||
16 | @@ -189,7 +189,12 @@ def all_literal_values(type_: type[core_schema.Literal]) -> list[any]: | ||
17 | |||
18 | def eval_forward_ref(type_: Any) -> Any: | ||
19 | try: | ||
20 | - return type_._evaluate(core_schema.__dict__, None, set()) | ||
21 | + try: | ||
22 | + # Python 3.12+ | ||
23 | + return type_._evaluate(core_schema.__dict__, None, type_params=set(), recursive_guard=set()) | ||
24 | + except TypeError: | ||
25 | + # Python 3.9+ | ||
26 | + return type_._evaluate(core_schema.__dict__, None, set()) | ||
27 | except TypeError: | ||
28 | # for Python 3.8 | ||
29 | return type_._evaluate(core_schema.__dict__, None) | ||
diff --git a/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb b/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb index f510645222..c5ce1ff110 100644 --- a/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb +++ b/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb | |||
@@ -8,7 +8,8 @@ HOMEPAGE = "https://github.com/pydantic/pydantic-core" | |||
8 | LICENSE = "MIT" | 8 | LICENSE = "MIT" |
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c" | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c" |
10 | 10 | ||
11 | SRC_URI += "file://0001-Bumps-pyo3-https-github.com-pyo3-pyo3-from-0.20.2-to.patch" | 11 | SRC_URI += "file://0001-Bumps-pyo3-https-github.com-pyo3-pyo3-from-0.20.2-to.patch \ |
12 | file://0001-Fix-generate_self_schema-for-Python-3.12-1299.patch" | ||
12 | SRC_URI[sha256sum] = "1cac689f80a3abab2d3c0048b29eea5751114054f032a941a32de4c852c59cad" | 13 | SRC_URI[sha256sum] = "1cac689f80a3abab2d3c0048b29eea5751114054f032a941a32de4c852c59cad" |
13 | 14 | ||
14 | DEPENDS = "python3-maturin-native python3-typing-extensions" | 15 | DEPENDS = "python3-maturin-native python3-typing-extensions" |