summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-backports-functools-lru-cache/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.1.bb15
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache/run-ptest b/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache/run-ptest
new file mode 100644
index 0000000000..b63c4de0d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.1.bb b/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.1.bb
index c95a759abf..e967958c02 100644
--- a/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.1.bb
+++ b/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.6.1.bb
@@ -11,7 +11,20 @@ SRC_URI[sha256sum] = "8fde5f188da2d593bd5bc0be98d9abc46c95bb8a9dde93429570192ee6
11 11
12DEPENDS += "${PYTHON_PN}-setuptools-scm-native" 12DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
13 13
14inherit pypi setuptools3 14inherit pypi setuptools3 ptest
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20RDEPENDS_${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
15 28
16RDEPENDS_${PN} += "\ 29RDEPENDS_${PN} += "\
17 ${PYTHON_PN}-pickle \ 30 ${PYTHON_PN}-pickle \