diff options
Diffstat (limited to 'meta-python')
4 files changed, 59 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-rfc3986-validator.inc b/meta-python/recipes-devtools/python/python-rfc3986-validator.inc new file mode 100644 index 0000000000..71f7a7904f --- /dev/null +++ b/meta-python/recipes-devtools/python/python-rfc3986-validator.inc | |||
@@ -0,0 +1,23 @@ | |||
1 | SUMMARY = "Pure python rfc3986 validator" | ||
2 | HOMEPAGE = "https://github.com/naimetti/rfc3986-validator" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6" | ||
5 | |||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3986-validator:" | ||
7 | |||
8 | SRC_URI[md5sum] = "47f7657b790aaf6011a1ab3d86c6be95" | ||
9 | SRC_URI[sha256sum] = "3d44bde7921b3b9ec3ae4e3adca370438eccebc676456449b145d533b240d055" | ||
10 | |||
11 | PYPI_PACKAGE = "rfc3986_validator" | ||
12 | |||
13 | inherit pypi | ||
14 | |||
15 | SRC_URI_append = " \ | ||
16 | file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS_${PN} += "\ | ||
20 | python3-core \ | ||
21 | " | ||
22 | |||
23 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-rfc3986-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch b/meta-python/recipes-devtools/python/python-rfc3986-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch new file mode 100644 index 0000000000..8a646874e8 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-rfc3986-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 3531ff73631a0d59234eb4713e7b3a7f5ea57bbb Mon Sep 17 00:00:00 2001 | ||
2 | From: Nicola Lunghi <nicola.lunghi@jci.com> | ||
3 | Date: Thu, 14 Nov 2019 12:17:51 +0000 | ||
4 | Subject: [PATCH] setup.py: move pytest-runner to test_requirements | ||
5 | |||
6 | This fixes an issue with yocto build. | ||
7 | pytest-runner is only needed when running tests. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | --- | ||
11 | setup.py | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index 53ebea7..ebb0de2 100644 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -10,9 +10,9 @@ with open('README.md') as readme_file: | ||
19 | |||
20 | requirements = [] | ||
21 | |||
22 | -setup_requirements = ['pytest-runner', ] | ||
23 | +setup_requirements = [] | ||
24 | |||
25 | -test_requirements = ['pytest>=3', ] | ||
26 | +test_requirements = ['pytest>=3', 'pytest-runner'] | ||
27 | |||
28 | setup( | ||
29 | author="Nicolas Aimetti", | ||
30 | -- | ||
31 | 2.20.1 | ||
32 | |||
diff --git a/meta-python/recipes-devtools/python/python-rfc3986-validator_0.1.1.bb b/meta-python/recipes-devtools/python/python-rfc3986-validator_0.1.1.bb new file mode 100644 index 0000000000..9dddbb4a99 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-rfc3986-validator_0.1.1.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-rfc3986-validator.inc \ No newline at end of file | ||
diff --git a/meta-python/recipes-devtools/python/python3-rfc3986-validator_0.1.1.bb b/meta-python/recipes-devtools/python/python3-rfc3986-validator_0.1.1.bb new file mode 100644 index 0000000000..6491308cbb --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-rfc3986-validator_0.1.1.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-rfc3986-validator.inc \ No newline at end of file | ||