summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pydantic-core/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-pydantic-core_2.27.2.bb9
2 files changed, 2 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pydantic-core/run-ptest b/meta-python/recipes-devtools/python/python3-pydantic-core/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-pydantic-core/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-pydantic-core_2.27.2.bb b/meta-python/recipes-devtools/python/python3-pydantic-core_2.27.2.bb
index 52571ff2cb..5dd76f99fa 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic-core_2.27.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic-core_2.27.2.bb
@@ -10,13 +10,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c"
10 10
11require ${BPN}-crates.inc 11require ${BPN}-crates.inc
12 12
13SRC_URI += "file://run-ptest"
14
15SRC_URI[sha256sum] = "eb026e5a4c1fee05726072337ff51d1efb6f59090b7da90d30ea58625b1ffb39" 13SRC_URI[sha256sum] = "eb026e5a4c1fee05726072337ff51d1efb6f59090b7da90d30ea58625b1ffb39"
16 14
17DEPENDS = "python3-maturin-native python3-typing-extensions" 15DEPENDS = "python3-maturin-native python3-typing-extensions"
18 16
19inherit pypi cargo-update-recipe-crates python_maturin 17inherit pypi cargo-update-recipe-crates python_maturin ptest-python-pytest
20 18
21PYPI_PACKAGE = "pydantic_core" 19PYPI_PACKAGE = "pydantic_core"
22UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}" 20UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
@@ -30,23 +28,20 @@ INSANE_SKIP:${PN} = "already-stripped"
30INSANE_SKIP:${PN} += "buildpaths" 28INSANE_SKIP:${PN} += "buildpaths"
31 29
32# python3-misc is for Lib/timeit.py which is not split out elsewhere 30# python3-misc is for Lib/timeit.py which is not split out elsewhere
33inherit ptest
34RDEPENDS:${PN}-ptest += "\ 31RDEPENDS:${PN}-ptest += "\
35 python3-dateutil \ 32 python3-dateutil \
36 python3-dirty-equals \ 33 python3-dirty-equals \
37 python3-hypothesis \ 34 python3-hypothesis \
38 python3-inline-snapshot \ 35 python3-inline-snapshot \
39 python3-misc \ 36 python3-misc \
40 python3-pytest \
41 python3-pytest-mock \ 37 python3-pytest-mock \
42 python3-pytest-timeout \ 38 python3-pytest-timeout \
43 python3-pytest-benchmark \ 39 python3-pytest-benchmark \
44 python3-tzdata \ 40 python3-tzdata \
45 python3-unittest-automake-output \
46 python3-zoneinfo \ 41 python3-zoneinfo \
47" 42"
48 43
49do_install_ptest() { 44do_install_ptest:append () {
50 cp -rf ${S}/tests/ ${D}${PTEST_PATH}/ 45 cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
51 sed -i -e "/--automake/ s/$/ -k 'not test_model_class_root_validator_wrap and not test_model_class_root_validator_before and not test_model_class_root_validator_after'/" ${D}${PTEST_PATH}/run-ptest 46 sed -i -e "/--automake/ s/$/ -k 'not test_model_class_root_validator_wrap and not test_model_class_root_validator_before and not test_model_class_root_validator_after'/" ${D}${PTEST_PATH}/run-ptest
52} 47}