diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-astroid/0001-pyproject.toml-Replace-with.patch | 27 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-astroid_2.13.2.bb (renamed from meta-python/recipes-devtools/python/python3-astroid_2.12.13.bb) | 13 |
2 files changed, 37 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-astroid/0001-pyproject.toml-Replace-with.patch b/meta-python/recipes-devtools/python/python3-astroid/0001-pyproject.toml-Replace-with.patch new file mode 100644 index 0000000000..3e1a17be92 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-astroid/0001-pyproject.toml-Replace-with.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 517f361ba4a6ae430acfe3b83986d32b4f811b58 Mon Sep 17 00:00:00 2001 | ||
2 | From: Leon Anavi <leon.anavi@konsulko.com> | ||
3 | Date: Wed, 11 Jan 2023 13:56:24 +0200 | ||
4 | Subject: [PATCH] pyproject.toml: Replace ~= with >= | ||
5 | |||
6 | Replace ~= with >= to avoid errors if the version is not exactly | ||
7 | the same. | ||
8 | |||
9 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
10 | --- | ||
11 | pyproject.toml | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/pyproject.toml b/pyproject.toml | ||
15 | index 537bca9a..a01e0d45 100644 | ||
16 | --- a/pyproject.toml | ||
17 | +++ b/pyproject.toml | ||
18 | @@ -1,5 +1,5 @@ | ||
19 | [build-system] | ||
20 | -requires = ["setuptools~=62.6", "wheel~=0.37.1"] | ||
21 | +requires = ["setuptools>=62.6", "wheel>=0.37.1"] | ||
22 | build-backend = "setuptools.build_meta" | ||
23 | |||
24 | [project] | ||
25 | -- | ||
26 | 2.30.2 | ||
27 | |||
diff --git a/meta-python/recipes-devtools/python/python3-astroid_2.12.13.bb b/meta-python/recipes-devtools/python/python3-astroid_2.13.2.bb index ca87ff013d..fa22080d36 100644 --- a/meta-python/recipes-devtools/python/python3-astroid_2.12.13.bb +++ b/meta-python/recipes-devtools/python/python3-astroid_2.13.2.bb | |||
@@ -4,11 +4,18 @@ SECTION = "devel/python" | |||
4 | LICENSE = "LGPL-2.1-only" | 4 | LICENSE = "LGPL-2.1-only" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1" |
6 | 6 | ||
7 | SRC_URI[sha256sum] = "1493fe8bd3dfd73dc35bd53c9d5b6e49ead98497c47b2307662556a5692d29d7" | 7 | SRC_URI[sha256sum] = "3bc7834720e1a24ca797fd785d77efb14f7a28ee8e635ef040b6e2d80ccb3303" |
8 | 8 | ||
9 | inherit pypi setuptools3 | 9 | SRC_URI += " \ |
10 | file://0001-pyproject.toml-Replace-with.patch \ | ||
11 | " | ||
12 | |||
13 | inherit pypi python_setuptools_build_meta | ||
10 | 14 | ||
11 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" | 15 | DEPENDS += "\ |
16 | ${PYTHON_PN}-pytest-runner-native \ | ||
17 | ${PYTHON_PN}-wheel-native \ | ||
18 | " | ||
12 | 19 | ||
13 | PACKAGES =+ "${PN}-tests" | 20 | PACKAGES =+ "${PN}-tests" |
14 | 21 | ||