diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyjks.inc | 22 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyjks_19.0.0.bb | 24 |
2 files changed, 22 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyjks.inc b/meta-python/recipes-devtools/python/python-pyjks.inc deleted file mode 100644 index 9a066f7f1d..0000000000 --- a/meta-python/recipes-devtools/python/python-pyjks.inc +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | SUMMARY = "Pure-Python Java Keystore (JKS) library" | ||
2 | DESCRIPTION = "PyJKS enables Python projects to load and manipulate\ | ||
3 | Java KeyStore (JKS) data without a JVM dependency. PyJKS supports JKS,\ | ||
4 | JCEKS, BKS and UBER (BouncyCastle) keystores." | ||
5 | HOMEPAGE = "http://github.com/kurtbrose/pyjks" | ||
6 | LICENSE = "MIT" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9694d6cc724caf7f7386be88a4a81958" | ||
8 | |||
9 | SRC_URI[md5sum] = "b6e8f3b91be355d15e3ba99de2cccf9b" | ||
10 | SRC_URI[sha256sum] = "9ce5b40289bcdffcd6a8e7118b333ba8ba2ec4c9ebc5e324885cc8a69767011a" | ||
11 | |||
12 | inherit pypi | ||
13 | |||
14 | RDEPENDS_${PN} = "\ | ||
15 | ${PYTHON_PN}-javaobj-py3 \ | ||
16 | ${PYTHON_PN}-pyasn1 \ | ||
17 | ${PYTHON_PN}-pyasn1-modules \ | ||
18 | ${PYTHON_PN}-pycryptodome \ | ||
19 | ${PYTHON_PN}-twofish\ | ||
20 | " | ||
21 | |||
22 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyjks_19.0.0.bb b/meta-python/recipes-devtools/python/python3-pyjks_19.0.0.bb index 8982fcebc3..ee2f3075ca 100644 --- a/meta-python/recipes-devtools/python/python3-pyjks_19.0.0.bb +++ b/meta-python/recipes-devtools/python/python3-pyjks_19.0.0.bb | |||
@@ -1,2 +1,22 @@ | |||
1 | require python-pyjks.inc | 1 | SUMMARY = "Pure-Python Java Keystore (JKS) library" |
2 | inherit setuptools3 | 2 | DESCRIPTION = "PyJKS enables Python projects to load and manipulate\ |
3 | Java KeyStore (JKS) data without a JVM dependency. PyJKS supports JKS,\ | ||
4 | JCEKS, BKS and UBER (BouncyCastle) keystores." | ||
5 | HOMEPAGE = "http://github.com/kurtbrose/pyjks" | ||
6 | LICENSE = "MIT" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9694d6cc724caf7f7386be88a4a81958" | ||
8 | |||
9 | SRC_URI[md5sum] = "b6e8f3b91be355d15e3ba99de2cccf9b" | ||
10 | SRC_URI[sha256sum] = "9ce5b40289bcdffcd6a8e7118b333ba8ba2ec4c9ebc5e324885cc8a69767011a" | ||
11 | |||
12 | inherit pypi setuptools3 | ||
13 | |||
14 | RDEPENDS_${PN} = "\ | ||
15 | ${PYTHON_PN}-javaobj-py3 \ | ||
16 | ${PYTHON_PN}-pyasn1 \ | ||
17 | ${PYTHON_PN}-pyasn1-modules \ | ||
18 | ${PYTHON_PN}-pycryptodome \ | ||
19 | ${PYTHON_PN}-twofish\ | ||
20 | " | ||
21 | |||
22 | BBCLASSEXTEND = "native nativesdk" | ||