summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-pkcs11_0.7.0.bb25
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 2fd056de7d..ea5683ce68 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -272,6 +272,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
272 python3-pika \ 272 python3-pika \
273 python3-pillow \ 273 python3-pillow \
274 python3-pint \ 274 python3-pint \
275 python3-pkcs11 \
275 python3-pkgconfig \ 276 python3-pkgconfig \
276 python3-ply \ 277 python3-ply \
277 python3-pocketsphinx \ 278 python3-pocketsphinx \
diff --git a/meta-python/recipes-devtools/python/python3-pkcs11_0.7.0.bb b/meta-python/recipes-devtools/python/python3-pkcs11_0.7.0.bb
new file mode 100644
index 0000000000..816b728dc0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pkcs11_0.7.0.bb
@@ -0,0 +1,25 @@
1SUMMARY = "PKCS#11 (Cryptoki) support for Python"
2DESCRIPTION = "A high level, “more Pythonic” interface to the PKCS#11 (Cryptoki) standard to support HSM and Smartcard devices in Python."
3HOMEPAGE = "https://pypi.org/project/python-pkcs11/"
4SECTION = "devel/python"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://README.rst;beginline=337;endline=358;md5=f68bda54505b4002e6ec86e08125ef79"
7
8SRC_URI[sha256sum] = "9737e0c24cabb8bc9d48bf8c57c3df2a70f8cdd96b70c50290803286f9e46bf7"
9
10PYPI_PACKAGE = "python-pkcs11"
11
12inherit pypi setuptools3
13
14BBCLASSEXTEND = "native"
15
16DEPENDS += " \
17 python3-cython-native \
18 python3-setuptools-scm-native \
19 python3 \
20"
21
22RDEPENDS:${PN} += " \
23 python3-asn1crypto \
24 python3-cached-property \
25"