diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-polyline/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb | 15 |
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-polyline/run-ptest b/meta-python/recipes-devtools/python/python3-polyline/run-ptest new file mode 100644 index 0000000000..5cec711696 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-polyline/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb b/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb index 3b3e2071f1..d81ee5445c 100644 --- a/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb +++ b/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb | |||
@@ -6,8 +6,21 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=0fbd13500cabd06dd751ba6b2be304c6" | |||
6 | SRC_URI[md5sum] = "b97c57378605c4a856c437569f95a0cb" | 6 | SRC_URI[md5sum] = "b97c57378605c4a856c437569f95a0cb" |
7 | SRC_URI[sha256sum] = "7c7f89d09a09c7b6161bdbfb4fd304b186fc7a2060fa4f31cb3f61c646a5c074" | 7 | SRC_URI[sha256sum] = "7c7f89d09a09c7b6161bdbfb4fd304b186fc7a2060fa4f31cb3f61c646a5c074" |
8 | 8 | ||
9 | inherit pypi setuptools3 | 9 | inherit pypi setuptools3 ptest |
10 | 10 | ||
11 | RDEPENDS_${PN} += "python3-six" | 11 | RDEPENDS_${PN} += "python3-six" |
12 | 12 | ||
13 | BBCLASSEXTEND = "native nativesdk" | 13 | BBCLASSEXTEND = "native nativesdk" |
14 | |||
15 | SRC_URI += " \ | ||
16 | file://run-ptest \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS_${PN}-ptest += " \ | ||
20 | ${PYTHON_PN}-pytest \ | ||
21 | " | ||
22 | |||
23 | do_install_ptest() { | ||
24 | install -d ${D}${PTEST_PATH}/test | ||
25 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/ | ||
26 | } | ||