diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ujson/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb | 13 |
2 files changed, 1 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson/run-ptest b/meta-python/recipes-devtools/python/python3-ujson/run-ptest deleted file mode 100644 index 4863c5e5a3..0000000000 --- a/meta-python/recipes-devtools/python/python3-ujson/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | FORCE_COLOR=1 pytest --automake --capture=no | ||
diff --git a/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb b/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb index 5f4439c4c3..48d51e6fbf 100644 --- a/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb +++ b/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb | |||
@@ -6,17 +6,13 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e0039a83d8a99726b5 | |||
6 | 6 | ||
7 | SRC_URI[sha256sum] = "b3cd8f3c5d8c7738257f1018880444f7b7d9b66232c64649f562d7ba86ad4bc1" | 7 | SRC_URI[sha256sum] = "b3cd8f3c5d8c7738257f1018880444f7b7d9b66232c64649f562d7ba86ad4bc1" |
8 | 8 | ||
9 | inherit pypi ptest python_setuptools_build_meta | 9 | inherit pypi ptest-python-pytest python_setuptools_build_meta |
10 | 10 | ||
11 | # let OE do the strip operation | 11 | # let OE do the strip operation |
12 | export UJSON_BUILD_NO_STRIP = "1" | 12 | export UJSON_BUILD_NO_STRIP = "1" |
13 | 13 | ||
14 | DEPENDS += "python3-setuptools-scm-native" | 14 | DEPENDS += "python3-setuptools-scm-native" |
15 | 15 | ||
16 | SRC_URI += " \ | ||
17 | file://run-ptest \ | ||
18 | " | ||
19 | |||
20 | RDEPENDS:${PN} += "\ | 16 | RDEPENDS:${PN} += "\ |
21 | python3-datetime \ | 17 | python3-datetime \ |
22 | python3-numbers \ | 18 | python3-numbers \ |
@@ -25,14 +21,7 @@ RDEPENDS:${PN} += "\ | |||
25 | RDEPENDS:${PN}-ptest += " \ | 21 | RDEPENDS:${PN}-ptest += " \ |
26 | python3-json \ | 22 | python3-json \ |
27 | python3-misc \ | 23 | python3-misc \ |
28 | python3-pytest \ | ||
29 | python3-pytz \ | 24 | python3-pytz \ |
30 | python3-unittest-automake-output \ | ||
31 | " | 25 | " |
32 | 26 | ||
33 | do_install_ptest() { | ||
34 | install -d ${D}${PTEST_PATH}/tests | ||
35 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
36 | } | ||
37 | |||
38 | BBCLASSEXTEND = "native nativesdk" | 27 | BBCLASSEXTEND = "native nativesdk" |