diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pytz/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pytz_2019.3.bb | 18 |
2 files changed, 20 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytz/run-ptest b/meta-python/recipes-devtools/python/python3-pytz/run-ptest new file mode 100644 index 0000000000..5cec711696 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pytz/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb b/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb index ffe336d2c3..c28a0148bc 100644 --- a/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb +++ b/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "http://pythonhosted.org/pytz" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4878a915709225bceab739bdc2a18e8d" | 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4878a915709225bceab739bdc2a18e8d" |
5 | 5 | ||
6 | inherit pypi setuptools3 | 6 | inherit pypi setuptools3 ptest |
7 | 7 | ||
8 | SRC_URI[md5sum] = "c3d84a465fc56a4edd52cca8873ac0df" | 8 | SRC_URI[md5sum] = "c3d84a465fc56a4edd52cca8873ac0df" |
9 | SRC_URI[sha256sum] = "b02c06db6cf09c12dd25137e563b31700d3b80fcc4ad23abb7a315f2789819be" | 9 | SRC_URI[sha256sum] = "b02c06db6cf09c12dd25137e563b31700d3b80fcc4ad23abb7a315f2789819be" |
@@ -18,3 +18,19 @@ RDEPENDS_${PN}_class-target += "\ | |||
18 | " | 18 | " |
19 | 19 | ||
20 | BBCLASSEXTEND = "native nativesdk" | 20 | BBCLASSEXTEND = "native nativesdk" |
21 | |||
22 | SRC_URI += " \ | ||
23 | file://run-ptest \ | ||
24 | " | ||
25 | |||
26 | RDEPENDS_${PN}-ptest += " \ | ||
27 | ${PYTHON_PN}-pytest \ | ||
28 | " | ||
29 | |||
30 | do_install_ptest() { | ||
31 | install -d ${D}${PTEST_PATH}/pytz | ||
32 | install -d ${D}${PTEST_PATH}/pytz/tests | ||
33 | cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/ | ||
34 | cp -f ${S}/README.txt ${D}${PTEST_PATH}/ | ||
35 | |||
36 | } | ||