summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-dominate/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-dominate_2.9.1.bb13
2 files changed, 1 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dominate/run-ptest b/meta-python/recipes-devtools/python/python3-dominate/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-dominate/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-dominate_2.9.1.bb b/meta-python/recipes-devtools/python/python3-dominate_2.9.1.bb
index cce304498a..a0dd638087 100644
--- a/meta-python/recipes-devtools/python/python3-dominate_2.9.1.bb
+++ b/meta-python/recipes-devtools/python/python3-dominate_2.9.1.bb
@@ -4,23 +4,12 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
4 4
5SRC_URI[sha256sum] = "558284687d9b8aae1904e3d6051ad132dd4a8c0cf551b37ea4e7e42a31d19dc4" 5SRC_URI[sha256sum] = "558284687d9b8aae1904e3d6051ad132dd4a8c0cf551b37ea4e7e42a31d19dc4"
6 6
7inherit pypi ptest python_setuptools_build_meta 7inherit pypi ptest-python-pytest python_setuptools_build_meta
8 8
9SRC_URI += " \ 9SRC_URI += " \
10 file://58f7d7fdb171f80ed6ce97e6ca4409723975c47f.patch \ 10 file://58f7d7fdb171f80ed6ce97e6ca4409723975c47f.patch \
11 file://run-ptest \
12" 11"
13 12
14RDEPENDS:${PN}-ptest += " \
15 python3-pytest \
16 python3-unittest-automake-output \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS:${PN} += "\ 13RDEPENDS:${PN} += "\
25 python3-numbers \ 14 python3-numbers \
26 python3-threading \ 15 python3-threading \