summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-urllib3.inc21
-rw-r--r--meta-python/recipes-devtools/python/python3-urllib3_1.25.7.bb23
2 files changed, 22 insertions, 22 deletions
diff --git a/meta-python/recipes-devtools/python/python-urllib3.inc b/meta-python/recipes-devtools/python/python-urllib3.inc
deleted file mode 100644
index b7edc03f0c..0000000000
--- a/meta-python/recipes-devtools/python/python-urllib3.inc
+++ /dev/null
@@ -1,21 +0,0 @@
1SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
2HOMEPAGE = "https://github.com/shazow/urllib3"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=65715c2eb961313d71b297dd5a04f85e"
5
6SRC_URI[md5sum] = "85e1e3925f8c1095172bff343f3312ed"
7SRC_URI[sha256sum] = "f3c5fd51747d450d4dcf6f923c81f78f811aab8205fda64b0aba34a4e48b0745"
8
9RDEPENDS_${PN} += "\
10 ${PYTHON_PN}-certifi \
11 ${PYTHON_PN}-cryptography \
12 ${PYTHON_PN}-email \
13 ${PYTHON_PN}-idna \
14 ${PYTHON_PN}-netclient \
15 ${PYTHON_PN}-pyopenssl \
16 ${PYTHON_PN}-threading \
17"
18
19CVE_PRODUCT = "urllib3"
20
21BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-urllib3_1.25.7.bb b/meta-python/recipes-devtools/python/python3-urllib3_1.25.7.bb
index 19eb7025b2..34c15b6c24 100644
--- a/meta-python/recipes-devtools/python/python3-urllib3_1.25.7.bb
+++ b/meta-python/recipes-devtools/python/python3-urllib3_1.25.7.bb
@@ -1,2 +1,23 @@
1SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
2HOMEPAGE = "https://github.com/shazow/urllib3"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=65715c2eb961313d71b297dd5a04f85e"
5
6SRC_URI[md5sum] = "85e1e3925f8c1095172bff343f3312ed"
7SRC_URI[sha256sum] = "f3c5fd51747d450d4dcf6f923c81f78f811aab8205fda64b0aba34a4e48b0745"
8
1inherit pypi setuptools3 9inherit pypi setuptools3
2require python-urllib3.inc 10
11RDEPENDS_${PN} += "\
12 ${PYTHON_PN}-certifi \
13 ${PYTHON_PN}-cryptography \
14 ${PYTHON_PN}-email \
15 ${PYTHON_PN}-idna \
16 ${PYTHON_PN}-netclient \
17 ${PYTHON_PN}-pyopenssl \
18 ${PYTHON_PN}-threading \
19"
20
21CVE_PRODUCT = "urllib3"
22
23BBCLASSEXTEND = "native nativesdk"