summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-py-cpuinfo/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-py-cpuinfo_9.0.0.bb3
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-py-cpuinfo/run-ptest b/meta-python/recipes-devtools/python/python3-py-cpuinfo/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-py-cpuinfo/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-py-cpuinfo/run-ptest
@@ -1,3 +1,3 @@
1#!/bin/sh 1#!/bin/sh
2 2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' 3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-py-cpuinfo_9.0.0.bb b/meta-python/recipes-devtools/python/python3-py-cpuinfo_9.0.0.bb
index 84172c058e..857afd1db7 100644
--- a/meta-python/recipes-devtools/python/python3-py-cpuinfo_9.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-py-cpuinfo_9.0.0.bb
@@ -17,7 +17,7 @@ SRC_URI += "file://run-ptest \
17do_install:append() { 17do_install:append() {
18 # Make sure we use /usr/bin/env python3 18 # Make sure we use /usr/bin/env python3
19 for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do 19 for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do
20 sed -i -e '1s|^#!.*|#!/usr/bin/env ${PYTHON_PN}|' $PYTHSCRIPT 20 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
21 done 21 done
22} 22}
23 23
@@ -28,6 +28,7 @@ do_install_ptest() {
28 28
29RDEPENDS:${PN}-ptest += "\ 29RDEPENDS:${PN}-ptest += "\
30 python3-pytest \ 30 python3-pytest \
31 python3-unittest-automake-output \
31" 32"
32 33
33RDEPENDS:${PN} += "python3-core python3-ctypes python3-datetime python3-json python3-io python3-mmap python3-multiprocessing python3-netclient python3-pickle python3-pprint python3-shell" 34RDEPENDS:${PN} += "python3-core python3-ctypes python3-datetime python3-json python3-io python3-mmap python3-multiprocessing python3-netclient python3-pickle python3-pprint python3-shell"