diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch | 20 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ujson_5.3.0.bb (renamed from meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb) | 4 |
2 files changed, 15 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch b/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch index 47da2b8cfc..42cd99a895 100644 --- a/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch +++ b/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch | |||
@@ -8,22 +8,28 @@ bitbake build errors related to already-stripped. | |||
8 | 8 | ||
9 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | 9 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> |
10 | --- | 10 | --- |
11 | setup.py | 2 +- | 11 | setup.py | 8 +------- |
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | 12 | 1 file changed, 1 insertion(+), 7 deletions(-) |
13 | 13 | ||
14 | diff --git a/setup.py b/setup.py | 14 | diff --git a/setup.py b/setup.py |
15 | index 453dc31..962c507 100644 | 15 | index b98963b..d42f07a 100644 |
16 | --- a/setup.py | 16 | --- a/setup.py |
17 | +++ b/setup.py | 17 | +++ b/setup.py |
18 | @@ -6,7 +6,7 @@ from setuptools import Extension, setup | 18 | @@ -19,13 +19,7 @@ if not dconv_libs: |
19 | dconv_source_files = glob("./deps/double-conversion/double-conversion/*.cc") | 19 | dconv_source_files.extend(glob("./deps/double-conversion/double-conversion/*.cc")) |
20 | dconv_source_files.append("./lib/dconv_wrapper.cc") | 20 | dconv_source_files.append("./lib/dconv_wrapper.cc") |
21 | 21 | ||
22 | -strip_flags = ["-Wl,--strip-all"] if platform.system() == "Linux" else [] | 22 | -if platform.system() == "Linux" and environ.get("UJSON_BUILD_NO_STRIP", "0") not in ( |
23 | - "1", | ||
24 | - "True", | ||
25 | -): | ||
26 | - strip_flags = ["-Wl,--strip-all"] | ||
27 | -else: | ||
28 | - strip_flags = [] | ||
23 | +strip_flags = [] | 29 | +strip_flags = [] |
24 | 30 | ||
25 | module1 = Extension( | 31 | module1 = Extension( |
26 | "ujson", | 32 | "ujson", |
27 | -- | 33 | -- |
28 | 2.30.2 | 34 | 2.25.1 |
29 | 35 | ||
diff --git a/meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb b/meta-python/recipes-devtools/python/python3-ujson_5.3.0.bb index 6c1bf7e82c..4c3ef82c92 100644 --- a/meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb +++ b/meta-python/recipes-devtools/python/python3-ujson_5.3.0.bb | |||
@@ -2,9 +2,9 @@ SUMMARY = "Ultra fast JSON encoder and decoder for Python" | |||
2 | DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3." | 2 | DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3." |
3 | 3 | ||
4 | LICENSE = "BSD-3-Clause" | 4 | LICENSE = "BSD-3-Clause" |
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe" | 5 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e0039a83d8a99726b5418f0b03302d0a" |
6 | 6 | ||
7 | SRC_URI[sha256sum] = "a88944d2f99db71a3ca0c63d81f37e55b660edde0b07216fb65a3e46403ef004" | 7 | SRC_URI[sha256sum] = "ab938777b3ac0372231ee654a7f6a13787e587b1ca268d8aa7e6fb6846e477d0" |
8 | 8 | ||
9 | inherit pypi ptest setuptools3 | 9 | inherit pypi ptest setuptools3 |
10 | 10 | ||