summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-cachecontrol_0.12.6.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.6.bb b/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.6.bb
new file mode 100644
index 0000000000..7c45ed3300
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.6.bb
@@ -0,0 +1,29 @@
1SUMMARY = "httplib2 caching for requests"
2HOMEPAGE = "https://pypi.org/project/CacheControl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6dc7e1b428eda03d850209fdbd6c71f1"
5
6# On PyPi, this is "CacheControl", rather than "cachecontrol", so we need to
7# override PYPI_PACKAGE so fetch succeeds.
8PYPI_PACKAGE = "CacheControl"
9
10SRC_URI[md5sum] = "5890b797f9b48b2b4cd1448cca89e396"
11SRC_URI[sha256sum] = "be9aa45477a134aee56c8fac518627e1154df063e85f67d4f83ce0ccc23688e8"
12
13inherit pypi setuptools3
14
15RDEPENDS_${PN} += "\
16 python3-crypt \
17 python3-datetime \
18 python3-email \
19 python3-lockfile \
20 python3-json \
21 python3-logging \
22 python3-msgpack \
23 python3-netclient \
24 python3-pickle \
25 python3-requests \
26 python3-urllib3 \
27"
28
29BBCLASSEXTEND = "native nativesdk"