summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyfanotify/0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch16
-rw-r--r--meta-python/recipes-devtools/python/python3-pyfanotify_0.2.2.bb (renamed from meta-python/recipes-devtools/python/python3-pyfanotify_0.2.1.bb)2
2 files changed, 8 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyfanotify/0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch b/meta-python/recipes-devtools/python/python3-pyfanotify/0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch
index 2fa3cb05d4..4c279bbcda 100644
--- a/meta-python/recipes-devtools/python/python3-pyfanotify/0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch
+++ b/meta-python/recipes-devtools/python/python3-pyfanotify/0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch
@@ -1,19 +1,20 @@
1From 9e7894b97ae7afe43a9901b774de5aef401549ac Mon Sep 17 00:00:00 2001 1From 87f1bf7d1e0ca2a841706d1c41d14382f11264db Mon Sep 17 00:00:00 2001
2From: Bartosz Golaszewski <brgl@bgdev.pl> 2From: Bartosz Golaszewski <brgl@bgdev.pl>
3Date: Thu, 28 Apr 2022 16:32:06 +0200 3Date: Thu, 28 Apr 2022 16:32:06 +0200
4Subject: [PATCH] ext: define FNM_EXTMATCH if not already defined 4Subject: [PATCH] ext: define FNM_EXTMATCH if not already defined
5 5
6On musl this constant is not defined. Define it locally if not present. 6On musl this constant is not defined. Define it locally if not present.
7 7
8Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
9---
10Upstream-Status: Inappropriate 8Upstream-Status: Inappropriate
11 9
10Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
11
12---
12 src/ext.c | 3 +++ 13 src/ext.c | 3 +++
13 1 file changed, 3 insertions(+) 14 1 file changed, 3 insertions(+)
14 15
15diff --git a/src/ext.c b/src/ext.c 16diff --git a/src/ext.c b/src/ext.c
16index e0bbe21..7d979d3 100644 17index fb33de1..fa01a81 100644
17--- a/src/ext.c 18--- a/src/ext.c
18+++ b/src/ext.c 19+++ b/src/ext.c
19@@ -19,6 +19,9 @@ 20@@ -19,6 +19,9 @@
@@ -24,8 +25,5 @@ index e0bbe21..7d979d3 100644
24+#define FNM_EXTMATCH 0 25+#define FNM_EXTMATCH 0
25+#endif 26+#endif
26 27
27 PyDoc_STRVAR(ext__doc__, 28 #define FUNUSED __attribute__((unused))
28 "Wrapper for fanotify.\n" 29
29--
302.34.1
31
diff --git a/meta-python/recipes-devtools/python/python3-pyfanotify_0.2.1.bb b/meta-python/recipes-devtools/python/python3-pyfanotify_0.2.2.bb
index c9fd07144c..292ceab2e3 100644
--- a/meta-python/recipes-devtools/python/python3-pyfanotify_0.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyfanotify_0.2.2.bb
@@ -5,7 +5,7 @@ LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=636a36c9df04efcfacf839b8866d9a37" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=636a36c9df04efcfacf839b8866d9a37"
6 6
7SRC_URI += "file://0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch" 7SRC_URI += "file://0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch"
8SRC_URI[sha256sum] = "fd62dccdf3c17ca117e3279f0cbc65c639e53c9dec8a459d44ed6a35c1a18e60" 8SRC_URI[sha256sum] = "90219aa9f8b78fa732f24aa7b21c7bb6ac97a6eb47f1763c899b8194e23af1df"
9 9
10inherit pypi setuptools3 10inherit pypi setuptools3
11 11