summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-fastjsonschema_2.21.1.bb11
2 files changed, 1 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest b/meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-fastjsonschema/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-fastjsonschema_2.21.1.bb b/meta-python/recipes-devtools/python/python3-fastjsonschema_2.21.1.bb
index ecd92d5a74..11fc6de8d6 100644
--- a/meta-python/recipes-devtools/python/python3-fastjsonschema_2.21.1.bb
+++ b/meta-python/recipes-devtools/python/python3-fastjsonschema_2.21.1.bb
@@ -8,14 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=18950e8362b69c0c617b42b8bd8e7532"
8 8
9SRC_URI[sha256sum] = "794d4f0a58f848961ba16af7b9c85a3e88cd360df008c59aac6fc5ae9323b5d4" 9SRC_URI[sha256sum] = "794d4f0a58f848961ba16af7b9c85a3e88cd360df008c59aac6fc5ae9323b5d4"
10 10
11SRC_URI += "file://run-ptest" 11inherit ptest-python-pytest pypi setuptools3
12
13inherit ptest pypi setuptools3
14
15do_install_ptest() {
16 install -d ${D}${PTEST_PATH}/tests
17 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
18}
19 12
20# python3-misc for timeit.py 13# python3-misc for timeit.py
21RDEPENDS:${PN}-ptest += "\ 14RDEPENDS:${PN}-ptest += "\
@@ -23,11 +16,9 @@ RDEPENDS:${PN}-ptest += "\
23 python3-jsonschema \ 16 python3-jsonschema \
24 python3-misc \ 17 python3-misc \
25 python3-pylint \ 18 python3-pylint \
26 python3-pytest \
27 python3-pytest-benchmark \ 19 python3-pytest-benchmark \
28 python3-pytest-cache \ 20 python3-pytest-cache \
29 python3-statistics \ 21 python3-statistics \
30 python3-unittest-automake-output \
31" 22"
32RDEPENDS:${PN} += "\ 23RDEPENDS:${PN} += "\
33 python3-core \ 24 python3-core \