diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb | 1 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-decouple_3.6.bb | 16 |
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb index 5f97bd9546..922a08af5b 100644 --- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb +++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb | |||
@@ -92,6 +92,7 @@ RDEPENDS:packagegroup-meta-python3 = "\ | |||
92 | python3-dbus-next \ | 92 | python3-dbus-next \ |
93 | python3-dbussy \ | 93 | python3-dbussy \ |
94 | python3-decorator \ | 94 | python3-decorator \ |
95 | python3-decouple \ | ||
95 | python3-defusedxml \ | 96 | python3-defusedxml \ |
96 | python3-dill \ | 97 | python3-dill \ |
97 | python3-diskcache \ | 98 | python3-diskcache \ |
diff --git a/meta-python/recipes-devtools/python/python3-decouple_3.6.bb b/meta-python/recipes-devtools/python/python3-decouple_3.6.bb new file mode 100644 index 0000000000..772ee7faf9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-decouple_3.6.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "Strict separation of settings from code." | ||
2 | HOMEPAGE = "https://github.com/henriquebastos/python-decouple/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a46375b26bb7d7603565d829a2a51782" | ||
6 | |||
7 | SRC_URI[sha256sum] = "2838cdf77a5cf127d7e8b339ce14c25bceb3af3e674e039d4901ba16359968c7" | ||
8 | |||
9 | PYPI_PACKAGE = "python-decouple" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | RDEPENDS:${PN} += " \ | ||
14 | python3-shell \ | ||
15 | python3-stringold \ | ||
16 | " | ||