summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-flask-sqlalchemy.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-flask-sqlalchemy_2.3.2.bb12
2 files changed, 11 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-sqlalchemy.inc b/meta-python/recipes-devtools/python/python-flask-sqlalchemy.inc
new file mode 100644
index 0000000000..e0efbc63ae
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-sqlalchemy.inc
@@ -0,0 +1,10 @@
1DESCRIPTION = "Adds SQLAlchemy support to your Flask application."
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=5ed1b8cc741515a835a7f6bf2f62ef4a"
4
5SRC_URI[md5sum] = "373ce61dfd03b593ad2eaba68c9fee35"
6SRC_URI[sha256sum] = "5971b9852b5888655f11db634e87725a9031e170f37c0ce7851cf83497f56e53"
7
8PYPI_PACKAGE = "Flask-SQLAlchemy"
9
10RDEPENDS_${PN} = "${PYTHON_PN}-sqlalchemy ${PYTHON_PN}-flask"
diff --git a/meta-python/recipes-devtools/python/python-flask-sqlalchemy_2.3.2.bb b/meta-python/recipes-devtools/python/python-flask-sqlalchemy_2.3.2.bb
index 76509171f1..3dc355c5da 100644
--- a/meta-python/recipes-devtools/python/python-flask-sqlalchemy_2.3.2.bb
+++ b/meta-python/recipes-devtools/python/python-flask-sqlalchemy_2.3.2.bb
@@ -1,12 +1,2 @@
1DESCRIPTION = "Adds SQLAlchemy support to your Flask application."
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=5ed1b8cc741515a835a7f6bf2f62ef4a"
4
5SRC_URI[md5sum] = "373ce61dfd03b593ad2eaba68c9fee35"
6SRC_URI[sha256sum] = "5971b9852b5888655f11db634e87725a9031e170f37c0ce7851cf83497f56e53"
7
8PYPI_PACKAGE = "Flask-SQLAlchemy"
9
10inherit pypi setuptools 1inherit pypi setuptools
11 2require python-flask-sqlalchemy.inc
12RDEPENDS_${PN} = "${PYTHON_PN}-sqlalchemy ${PYTHON_PN}-flask"