summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch50
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb12
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
new file mode 100644
index 0000000000..e032ceb2c9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
@@ -0,0 +1,50 @@
1Disable automatic downloading of components!
2
3Upstream-Status: Inappropriate [disable feature]
4
5Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
6
7--- a/setupext.py.orig 2021-12-14 09:44:33.499041044 -0800
8+++ a/setupext.py 2021-12-14 09:45:00.447041706 -0800
9@@ -64,40 +64,7 @@
10 BytesIO
11 The file loaded into memory.
12 """
13- cache_dir = _get_xdg_cache_dir()
14-
15- if cache_dir is not None: # Try to read from cache.
16- try:
17- data = (cache_dir / sha).read_bytes()
18- except IOError:
19- pass
20- else:
21- if _get_hash(data) == sha:
22- return BytesIO(data)
23-
24- # jQueryUI's website blocks direct downloads from urllib.request's
25- # default User-Agent, but not (for example) wget; so I don't feel too
26- # bad passing in an empty User-Agent.
27- with urllib.request.urlopen(
28- urllib.request.Request(url, headers={"User-Agent": ""}),
29- context=_get_ssl_context()) as req:
30- data = req.read()
31-
32- file_sha = _get_hash(data)
33- if file_sha != sha:
34- raise Exception(
35- f"The downloaded file does not match the expected sha. {url} was "
36- f"expected to have {sha} but it had {file_sha}")
37-
38- if cache_dir is not None: # Try to cache the downloaded file.
39- try:
40- cache_dir.mkdir(parents=True, exist_ok=True)
41- with open(cache_dir / sha, "xb") as fout:
42- fout.write(data)
43- except IOError:
44- pass
45-
46- return BytesIO(data)
47+ raise IOError(f"Automatic downloading is disabled.")
48
49
50 def get_and_extract_tarball(urls, sha, dirname):
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb
index f8448d5f1d..84bec0b201 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.5.1.bb
@@ -25,6 +25,18 @@ SRC_URI[sha256sum] = "b2e9810e09c3a47b73ce9cab5a72243a1258f61e7900969097a8172322
25 25
26inherit pypi setuptools3 pkgconfig 26inherit pypi setuptools3 pkgconfig
27 27
28# Stop the component from attempting to download when it detects a missing
29# dependency
30SRC_URI += "file://matplotlib-disable-download.patch"
31
32# This python module requires a full copy of freetype-2.6.1
33SRC_URI += "https://downloads.sourceforge.net/project/freetype/freetype2/2.6.1/freetype-2.6.1.tar.gz;name=freetype;subdir=matplotlib-${PV}/build"
34SRC_URI[freetype.sha256sum] = "0a3c7dfbda6da1e8fce29232e8e96d987ababbbf71ebc8c75659e4132c367014"
35
36# This python module requires a full copy of 'qhull-2020'
37SRC_URI += "http://www.qhull.org/download/qhull-2020-src-8.0.2.tgz;name=qhull;subdir=matplotlib-${PV}/build"
38SRC_URI[qhull.sha256sum] = "b5c2d7eb833278881b952c8a52d20179eab87766b00b865000469a45c1838b7e"
39
28# LTO with clang needs lld 40# LTO with clang needs lld
29LDFLAGS:append:toolchain-clang = " -fuse-ld=lld" 41LDFLAGS:append:toolchain-clang = " -fuse-ld=lld"
30LDFLAGS:remove:toolchain-clang:mips = "-fuse-ld=lld" 42LDFLAGS:remove:toolchain-clang:mips = "-fuse-ld=lld"