diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch | 10 | ||||
-rw-r--r-- | meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.26.bb (renamed from meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb) | 2 |
2 files changed, 6 insertions, 6 deletions
diff --git a/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch b/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch index e7533f4769..0e64ce420e 100644 --- a/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch +++ b/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch | |||
@@ -32,10 +32,10 @@ index bf08ac5..aada7aa 100644 | |||
32 | And some warning classes: | 32 | And some warning classes: |
33 | 33 | ||
34 | KickstartWarning - A generic warning class. | 34 | KickstartWarning - A generic warning class. |
35 | @@ -131,3 +134,17 @@ class KickstartDeprecationWarning(KickstartParseWarning, DeprecationWarning): | 35 | @@ -125,3 +128,17 @@ class KickstartDeprecationWarning(KickstartParseWarning, DeprecationWarning): |
36 | """A class for warnings occurring during parsing related to using deprecated | ||
36 | commands and options. | 37 | commands and options. |
37 | """ | 38 | """ |
38 | pass | ||
39 | + | 39 | + |
40 | +class KickstartAuthError(KickstartError): | 40 | +class KickstartAuthError(KickstartError): |
41 | + """An exception for errors relating to authentication failed while | 41 | + """An exception for errors relating to authentication failed while |
@@ -43,7 +43,7 @@ index bf08ac5..aada7aa 100644 | |||
43 | + """ | 43 | + """ |
44 | + def __init__(self, msg): | 44 | + def __init__(self, msg): |
45 | + """Create a new KickstartAuthError exception instance with the | 45 | + """Create a new KickstartAuthError exception instance with the |
46 | + descriptive message val. val should be the return value of | 46 | + descriptive message val. val should be the return value of |
47 | + formatErrorMsg. | 47 | + formatErrorMsg. |
48 | + """ | 48 | + """ |
49 | + KickstartError.__init__(self, msg) | 49 | + KickstartError.__init__(self, msg) |
@@ -125,7 +125,7 @@ diff --git a/pykickstart/parser.py b/pykickstart/parser.py | |||
125 | index d8880eb..22d14cb 100644 | 125 | index d8880eb..22d14cb 100644 |
126 | --- a/pykickstart/parser.py | 126 | --- a/pykickstart/parser.py |
127 | +++ b/pykickstart/parser.py | 127 | +++ b/pykickstart/parser.py |
128 | @@ -787,7 +787,7 @@ class KickstartParser(object): | 128 | @@ -801,7 +801,7 @@ class KickstartParser(object): |
129 | i = PutBackIterator(s.splitlines(True) + [""]) | 129 | i = PutBackIterator(s.splitlines(True) + [""]) |
130 | self._stateMachine(i) | 130 | self._stateMachine(i) |
131 | 131 | ||
@@ -134,7 +134,7 @@ index d8880eb..22d14cb 100644 | |||
134 | """Process a kickstart file, given by the filename f.""" | 134 | """Process a kickstart file, given by the filename f.""" |
135 | if reset: | 135 | if reset: |
136 | self._reset() | 136 | self._reset() |
137 | @@ -808,7 +808,7 @@ class KickstartParser(object): | 137 | @@ -822,7 +822,7 @@ class KickstartParser(object): |
138 | self.currentdir[self._includeDepth] = cd | 138 | self.currentdir[self._includeDepth] = cd |
139 | 139 | ||
140 | try: | 140 | try: |
diff --git a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.26.bb index 041abd3e8d..7aeb5d6c99 100644 --- a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb +++ b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.26.bb | |||
@@ -18,7 +18,7 @@ SRC_URI = "git://github.com/rhinstaller/pykickstart.git;protocol=https;branch=ma | |||
18 | file://0003-comment-out-sections-shutdown-and-environment-in-gen.patch \ | 18 | file://0003-comment-out-sections-shutdown-and-environment-in-gen.patch \ |
19 | file://0004-load.py-retry-to-invoke-request-with-timeout.patch \ | 19 | file://0004-load.py-retry-to-invoke-request-with-timeout.patch \ |
20 | " | 20 | " |
21 | SRCREV = "674c17b1e231f56a0d8a5ced4a204cdbc4c1edf3" | 21 | SRCREV = "4c93e84c8798da511da1c05f1912d2f908f8f85f" |
22 | 22 | ||
23 | UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)" | 23 | UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)" |
24 | 24 | ||