diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyroute2/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyroute2_0.5.11.bb | 16 |
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest b/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest new file mode 100644 index 0000000000..5cec711696 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2_0.5.11.bb b/meta-python/recipes-devtools/python/python3-pyroute2_0.5.11.bb index 58b538a45e..a4b8aa3988 100644 --- a/meta-python/recipes-devtools/python/python3-pyroute2_0.5.11.bb +++ b/meta-python/recipes-devtools/python/python3-pyroute2_0.5.11.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | |||
6 | SRC_URI[md5sum] = "7005db01604663fc2ecc089925980e05" | 6 | SRC_URI[md5sum] = "7005db01604663fc2ecc089925980e05" |
7 | SRC_URI[sha256sum] = "05e959f1a89d715158b91fe83b67946a4441e5e098cc225f4df78a3765ac4af2" | 7 | SRC_URI[sha256sum] = "05e959f1a89d715158b91fe83b67946a4441e5e098cc225f4df78a3765ac4af2" |
8 | 8 | ||
9 | inherit setuptools3 pypi | 9 | inherit setuptools3 pypi ptest |
10 | 10 | ||
11 | RDEPENDS_${PN} += " \ | 11 | RDEPENDS_${PN} += " \ |
12 | ${PYTHON_PN}-ctypes \ | 12 | ${PYTHON_PN}-ctypes \ |
@@ -21,3 +21,17 @@ RDEPENDS_${PN} += " \ | |||
21 | ${PYTHON_PN}-shell \ | 21 | ${PYTHON_PN}-shell \ |
22 | ${PYTHON_PN}-unixadmin \ | 22 | ${PYTHON_PN}-unixadmin \ |
23 | " | 23 | " |
24 | |||
25 | SRC_URI += " \ | ||
26 | file://run-ptest \ | ||
27 | " | ||
28 | |||
29 | RDEPENDS_${PN}-ptest += " \ | ||
30 | ${PYTHON_PN}-pytest \ | ||
31 | ${PYTHON_PN}-fcntl \ | ||
32 | " | ||
33 | |||
34 | do_install_ptest() { | ||
35 | install -d ${D}${PTEST_PATH}/tests | ||
36 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
37 | } | ||