summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio/0001-absl-always-use-asm-sgidefs.h.patch33
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio/abseil-ppc-fixes.patch28
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio_1.48.0.bb (renamed from meta-python/recipes-devtools/python/python3-grpcio_1.47.0.bb)5
3 files changed, 25 insertions, 41 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-absl-always-use-asm-sgidefs.h.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-absl-always-use-asm-sgidefs.h.patch
deleted file mode 100644
index be516ca508..0000000000
--- a/meta-python/recipes-devtools/python/python3-grpcio/0001-absl-always-use-asm-sgidefs.h.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 8f21fdfb83b0fa844a9f1f03a86a9ca46642d85e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 9 Apr 2020 13:06:27 -0700
4Subject: [PATCH 1/2] absl: always use <asm/sgidefs.h>
5
6Fixes mips/musl build, since sgidefs.h is not present on all C libraries
7but on linux asm/sgidefs.h is there and contains same definitions, using
8that makes it portable.
9
10Upstream-Status: Pending
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 third_party/abseil-cpp/absl/base/internal/direct_mmap.h | 6 +-----
15 1 file changed, 1 insertion(+), 5 deletions(-)
16
17--- a/third_party/abseil-cpp/absl/base/internal/direct_mmap.h
18+++ b/third_party/abseil-cpp/absl/base/internal/direct_mmap.h
19@@ -41,13 +41,9 @@
20
21 #ifdef __mips__
22 // Include definitions of the ABI currently in use.
23-#ifdef __BIONIC__
24-// Android doesn't have sgidefs.h, but does have asm/sgidefs.h, which has the
25+// bionic/musl C libs don't have sgidefs.h, but do have asm/sgidefs.h, which has the
26 // definitions we need.
27 #include <asm/sgidefs.h>
28-#else
29-#include <sgidefs.h>
30-#endif // __BIONIC__
31 #endif // __mips__
32
33 // SYS_mmap and SYS_munmap are not defined in Android.
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/abseil-ppc-fixes.patch b/meta-python/recipes-devtools/python/python3-grpcio/abseil-ppc-fixes.patch
index e8048fe940..c5fdcd63d2 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio/abseil-ppc-fixes.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio/abseil-ppc-fixes.patch
@@ -8,7 +8,16 @@ An all-in-one patch that fixes several issues:
8Sourced from void linux 8Sourced from void linux
9 9
10Signed-off-by: Khem Raj <raj.khem@gmail.com> 10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
12---
13 absl/base/internal/unscaledcycleclock.cc | 4 ++--
14 absl/base/internal/unscaledcycleclock.h | 3 ++-
15 absl/debugging/internal/examine_stack.cc | 8 +++++++-
16 absl/debugging/internal/stacktrace_config.h | 2 +-
17 4 files changed, 12 insertions(+), 5 deletions(-)
11 18
19diff --git a/absl/base/internal/unscaledcycleclock.cc b/absl/base/internal/unscaledcycleclock.cc
20index b1c396c..d62bfd6 100644
12--- a/absl/base/internal/unscaledcycleclock.cc 21--- a/absl/base/internal/unscaledcycleclock.cc
13+++ b/absl/base/internal/unscaledcycleclock.cc 22+++ b/absl/base/internal/unscaledcycleclock.cc
14@@ -20,7 +20,7 @@ 23@@ -20,7 +20,7 @@
@@ -20,7 +29,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
20 #ifdef __GLIBC__ 29 #ifdef __GLIBC__
21 #include <sys/platform/ppc.h> 30 #include <sys/platform/ppc.h>
22 #elif defined(__FreeBSD__) 31 #elif defined(__FreeBSD__)
23@@ -59,7 +59,7 @@ double UnscaledCycleClock::Frequency() { 32@@ -58,7 +58,7 @@ double UnscaledCycleClock::Frequency() {
24 return base_internal::NominalCPUFrequency(); 33 return base_internal::NominalCPUFrequency();
25 } 34 }
26 35
@@ -29,6 +38,8 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
29 38
30 int64_t UnscaledCycleClock::Now() { 39 int64_t UnscaledCycleClock::Now() {
31 #ifdef __GLIBC__ 40 #ifdef __GLIBC__
41diff --git a/absl/base/internal/unscaledcycleclock.h b/absl/base/internal/unscaledcycleclock.h
42index 2cbeae3..683a5ef 100644
32--- a/absl/base/internal/unscaledcycleclock.h 43--- a/absl/base/internal/unscaledcycleclock.h
33+++ b/absl/base/internal/unscaledcycleclock.h 44+++ b/absl/base/internal/unscaledcycleclock.h
34@@ -46,7 +46,8 @@ 45@@ -46,7 +46,8 @@
@@ -38,12 +49,14 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
38- defined(__powerpc__) || defined(__ppc__) || defined(__riscv) || \ 49- defined(__powerpc__) || defined(__ppc__) || defined(__riscv) || \
39+ ((defined(__powerpc__) || defined(__ppc__)) && defined(__GLIBC__)) || \ 50+ ((defined(__powerpc__) || defined(__ppc__)) && defined(__GLIBC__)) || \
40+ defined(__riscv) || \ 51+ defined(__riscv) || \
41 defined(_M_IX86) || defined(_M_X64) 52 defined(_M_IX86) || (defined(_M_X64) && !defined(_M_ARM64EC))
42 #define ABSL_HAVE_UNSCALED_CYCLECLOCK_IMPLEMENTATION 1 53 #define ABSL_HAVE_UNSCALED_CYCLECLOCK_IMPLEMENTATION 1
43 #else 54 #else
55diff --git a/absl/debugging/internal/examine_stack.cc b/absl/debugging/internal/examine_stack.cc
56index 5bdd341..a784e0d 100644
44--- a/absl/debugging/internal/examine_stack.cc 57--- a/absl/debugging/internal/examine_stack.cc
45+++ b/absl/debugging/internal/examine_stack.cc 58+++ b/absl/debugging/internal/examine_stack.cc
46@@ -27,6 +27,10 @@ 59@@ -33,6 +33,10 @@
47 #include <csignal> 60 #include <csignal>
48 #include <cstdio> 61 #include <cstdio>
49 62
@@ -54,7 +67,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
54 #include "absl/base/attributes.h" 67 #include "absl/base/attributes.h"
55 #include "absl/base/internal/raw_logging.h" 68 #include "absl/base/internal/raw_logging.h"
56 #include "absl/base/macros.h" 69 #include "absl/base/macros.h"
57@@ -63,8 +67,10 @@ void* GetProgramCounter(void* vuc) { 70@@ -174,8 +178,10 @@ void* GetProgramCounter(void* const vuc) {
58 return reinterpret_cast<void*>(context->uc_mcontext.pc); 71 return reinterpret_cast<void*>(context->uc_mcontext.pc);
59 #elif defined(__powerpc64__) 72 #elif defined(__powerpc64__)
60 return reinterpret_cast<void*>(context->uc_mcontext.gp_regs[32]); 73 return reinterpret_cast<void*>(context->uc_mcontext.gp_regs[32]);
@@ -66,9 +79,11 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
66 #elif defined(__riscv) 79 #elif defined(__riscv)
67 return reinterpret_cast<void*>(context->uc_mcontext.__gregs[REG_PC]); 80 return reinterpret_cast<void*>(context->uc_mcontext.__gregs[REG_PC]);
68 #elif defined(__s390__) && !defined(__s390x__) 81 #elif defined(__s390__) && !defined(__s390x__)
82diff --git a/absl/debugging/internal/stacktrace_config.h b/absl/debugging/internal/stacktrace_config.h
83index 3929b1b..23d5e50 100644
69--- a/absl/debugging/internal/stacktrace_config.h 84--- a/absl/debugging/internal/stacktrace_config.h
70+++ b/absl/debugging/internal/stacktrace_config.h 85+++ b/absl/debugging/internal/stacktrace_config.h
71@@ -59,7 +59,7 @@ 86@@ -60,7 +60,7 @@
72 #elif defined(__i386__) || defined(__x86_64__) 87 #elif defined(__i386__) || defined(__x86_64__)
73 #define ABSL_STACKTRACE_INL_HEADER \ 88 #define ABSL_STACKTRACE_INL_HEADER \
74 "absl/debugging/internal/stacktrace_x86-inl.inc" 89 "absl/debugging/internal/stacktrace_x86-inl.inc"
@@ -77,3 +92,6 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
77 #define ABSL_STACKTRACE_INL_HEADER \ 92 #define ABSL_STACKTRACE_INL_HEADER \
78 "absl/debugging/internal/stacktrace_powerpc-inl.inc" 93 "absl/debugging/internal/stacktrace_powerpc-inl.inc"
79 #elif defined(__aarch64__) 94 #elif defined(__aarch64__)
95--
962.25.1
97
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.47.0.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.48.0.bb
index 0950114b02..a16b88093a 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio_1.47.0.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio_1.48.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/" 2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python" 3SECTION = "devel/python"
4LICENSE = "Apache-2.0 & BSD-3-Clause" 4LICENSE = "Apache-2.0 & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6e4cf218112648d22420a84281b68b88" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=731e401b36f8077ae0c134b59be5c906"
6 6
7DEPENDS += "${PYTHON_PN}-protobuf" 7DEPENDS += "${PYTHON_PN}-protobuf"
8 8
@@ -10,10 +10,9 @@ SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
10SRC_URI:append:class-target = " file://ppc-boringssl-support.patch \ 10SRC_URI:append:class-target = " file://ppc-boringssl-support.patch \
11 file://boring_ssl.patch \ 11 file://boring_ssl.patch \
12 file://mips_bigendian.patch \ 12 file://mips_bigendian.patch \
13 file://0001-absl-always-use-asm-sgidefs.h.patch \
14 file://abseil-ppc-fixes.patch;patchdir=third_party/abseil-cpp \ 13 file://abseil-ppc-fixes.patch;patchdir=third_party/abseil-cpp \
15" 14"
16SRC_URI[sha256sum] = "5dbba95fab9b35957b4977b8904fc1fa56b302f9051eff4d7716ebb0c087f801" 15SRC_URI[sha256sum] = "eaf4bb73819863440727195411ab3b5c304f6663625e66f348e91ebe0a039306"
17 16
18RDEPENDS:${PN} = "${PYTHON_PN}-protobuf \ 17RDEPENDS:${PN} = "${PYTHON_PN}-protobuf \
19 ${PYTHON_PN}-setuptools \ 18 ${PYTHON_PN}-setuptools \