diff options
Diffstat (limited to 'meta-python')
4 files changed, 31 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-inflection.inc b/meta-python/recipes-devtools/python/python-inflection.inc deleted file mode 100644 index 556b26820f..0000000000 --- a/meta-python/recipes-devtools/python/python-inflection.inc +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | SUMMARY = "A port of Ruby on Rails' inflection to Python." | ||
2 | HOMEPAGE = "https://pypi.org/project/inflection" | ||
3 | LICENSE = "MIT" | ||
4 | SECTION = "devel/python" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=de7833d9c2ce0052a4073928c76a13d7" | ||
6 | |||
7 | SRC_URI[md5sum] = "7941165e9f148e0520023941c0886b40" | ||
8 | SRC_URI[sha256sum] = "18ea7fb7a7d152853386523def08736aa8c32636b047ade55f7578c4edeb16ca" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | RDEPENDS_${PN} += "${PYTHON_PN}-pytest" | ||
13 | |||
14 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-inflection/run-ptest b/meta-python/recipes-devtools/python/python3-inflection/run-ptest new file mode 100644 index 0000000000..0caffb794c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-inflection/run-ptest | |||
@@ -0,0 +1,4 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO test_inflection.py | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
4 | |||
diff --git a/meta-python/recipes-devtools/python/python3-inflection_0.3.1.bb b/meta-python/recipes-devtools/python/python3-inflection_0.3.1.bb deleted file mode 100644 index cc36a02a77..0000000000 --- a/meta-python/recipes-devtools/python/python3-inflection_0.3.1.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-inflection.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-inflection_0.5.0.bb b/meta-python/recipes-devtools/python/python3-inflection_0.5.0.bb new file mode 100644 index 0000000000..0a3b7734cf --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-inflection_0.5.0.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | SUMMARY = "A port of Ruby on Rails' inflection to Python." | ||
2 | HOMEPAGE = "https://pypi.org/project/inflection" | ||
3 | LICENSE = "MIT" | ||
4 | SECTION = "devel/python" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2fb6fa1a6f1792d78de19ad1bb653c31" | ||
6 | |||
7 | SRC_URI[md5sum] = "87b2ab6ffdd6e15aa31d109ce5ff10bb" | ||
8 | SRC_URI[sha256sum] = "f576e85132d34f5bf7df5183c2c6f94cfb32e528f53065345cf71329ba0b8924" | ||
9 | |||
10 | inherit pypi setuptools3 ptest | ||
11 | |||
12 | SRC_URI +=" \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | |||
16 | RDEPENDS_${PN}_ptest +=" \ | ||
17 | ${PYTHON_PN}_pytest \ | ||
18 | " | ||
19 | |||
20 | do_install_ptest() { | ||
21 | cp -f ${S}/test_inflection.py ${D}${PTEST_PATH}/ | ||
22 | } | ||
23 | |||
24 | |||
25 | RDEPENDS_${PN} += "${PYTHON_PN}-pytest" | ||
26 | |||
27 | BBCLASSEXTEND = "native nativesdk" | ||