summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-elementpath_2.1.2.bb12
-rw-r--r--meta-python/recipes-devtools/python/python3-xmlschema_1.4.1.bb20
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-elementpath_2.1.2.bb b/meta-python/recipes-devtools/python/python3-elementpath_2.1.2.bb
new file mode 100644
index 0000000000..f47f152229
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-elementpath_2.1.2.bb
@@ -0,0 +1,12 @@
1DESCRIPTION = "Provide XPath 1.0 and 2.0 selectors for Python's ElementTree XML data structures, both for the standard ElementTree library and for the lxml.etree library."
2HOMEPAGE = "https://github.com/sissaschool/elementpath"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5dbb7fb7d72da3921202dd7b995d3ecf"
5
6SRC_URI[md5sum] = "887f60e9c4fb9b0804a38372b2798101"
7SRC_URI[sha256sum] = "23e1fed8d196d9a6cc4d220ef11fbe7eb8cff3a27848621c447e9d96134b2085"
8
9PYPI_PACKAGE = "elementpath"
10inherit pypi setuptools3
11
12BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-xmlschema_1.4.1.bb b/meta-python/recipes-devtools/python/python3-xmlschema_1.4.1.bb
new file mode 100644
index 0000000000..c609931056
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xmlschema_1.4.1.bb
@@ -0,0 +1,20 @@
1SUMMARY = "The xmlschema library is an implementation of XML Schema for Python (supports Python 3.6+)."
2HOMEPAGE = "https://github.com/sissaschool/xmlschema"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=47489cb18c469474afeb259ed1d4832f"
5
6SRC_URI[md5sum] = "f4c46f8c4415a0ca31dc2f623b668664"
7SRC_URI[sha256sum] = "ade693114ff2e4a9ed5a2371ce29ae888f689bc58e326e5796f8a7dc8954dd4a"
8
9PYPI_PACKAGE = "xmlschema"
10inherit pypi setuptools3
11
12DEPENDS += "\
13 ${PYTHON_PN}-elementpath \
14"
15
16RDEPENDS_${PN} += "\
17 ${PYTHON_PN}-elementpath \
18"
19
20BBCLASSEXTEND = "native nativesdk"