diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-06-18 10:52:40 +0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-07-04 17:12:38 -0300 |
commit | 0263af75c053d1d7ea4882a75cf59b230fbb88ad (patch) | |
tree | 6cd09dd0835f539aac0a2aa404f4e5a3c13926d6 | |
parent | a4f88b6b5f0703d15c4b50589d36fd6df22cd330 (diff) | |
download | meta-qt5-0263af75c053d1d7ea4882a75cf59b230fbb88ad.tar.gz |
qt5: add option to build Qt5 statically
Add PACKAGECONFIG that enables static build for qtbase and consequently
to all Qt recipes. This can be enabled with DISTRO_FEATURE 'qt5-static',
which also adds qtdeclarative-native dependency to all recipes that
depend on qtdeclarative as it's required for qmlimportscannertool.
Building examples and tests with static build can take excessive amounts
of time and disk space, so disabling DISTRO_FEATURE 'ptest' and
PACKAGECONFIGs 'examples' from qtbase is advised.
Not all recipes support static builds and those are not fixed here.
Change-Id: Ia0e2a2467cd42d4395ed5292a645fd1d89ad521a
Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r-- | recipes-qt/qt5/qt5.inc | 22 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtdeclarative_git.bb | 3 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine_git.bb | 4 |
4 files changed, 30 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc index b4915138..99105bd9 100644 --- a/recipes-qt/qt5/qt5.inc +++ b/recipes-qt/qt5/qt5.inc | |||
@@ -37,6 +37,14 @@ python __anonymous() { | |||
37 | d.setVar("PACKAGE_ARCH", tarch) | 37 | d.setVar("PACKAGE_ARCH", tarch) |
38 | } | 38 | } |
39 | 39 | ||
40 | # if building static Qt5, add qtdeclarative-native dependency to all recipes | ||
41 | # that depend on qtdeclarative as it's required for qmlimportscannertool | ||
42 | python __anonymous() { | ||
43 | if bb.utils.contains('DISTRO_FEATURES', "qt5-static", True, False, d): | ||
44 | if bb.utils.contains('DEPENDS', "qtdeclarative", True, False, d): | ||
45 | d.appendVar("DEPENDS", " qtdeclarative-native") | ||
46 | } | ||
47 | |||
40 | # Many examples come with libraries installed outside of standard libdir, | 48 | # Many examples come with libraries installed outside of standard libdir, |
41 | # suppress QA check complaining | 49 | # suppress QA check complaining |
42 | INSANE_SKIP_${PN}-dbg += "libdir" | 50 | INSANE_SKIP_${PN}-dbg += "libdir" |
@@ -48,6 +56,8 @@ PACKAGES =. "${PN}-qmlplugins-dbg ${PN}-tools-dbg ${PN}-plugins-dbg ${PN}-qmldes | |||
48 | 56 | ||
49 | ALLOW_EMPTY_${PN} = "1" | 57 | ALLOW_EMPTY_${PN} = "1" |
50 | ALLOW_EMPTY_${PN}-dbg = "1" | 58 | ALLOW_EMPTY_${PN}-dbg = "1" |
59 | ALLOW_EMPTY_${PN}-plugins = "1" | ||
60 | ALLOW_EMPTY_${PN}-qmlplugins = "1" | ||
51 | 61 | ||
52 | RRECOMMENDS_${PN} = " \ | 62 | RRECOMMENDS_${PN} = " \ |
53 | ${PN}-plugins \ | 63 | ${PN}-plugins \ |
@@ -159,6 +169,18 @@ FILES_${PN}-dbg += " \ | |||
159 | " | 169 | " |
160 | FILES_${PN}-staticdev += " \ | 170 | FILES_${PN}-staticdev += " \ |
161 | ${OE_QMAKE_PATH_LIBS}/*.a \ | 171 | ${OE_QMAKE_PATH_LIBS}/*.a \ |
172 | ${OE_QMAKE_PATH_PLUGINS}/*/*.a \ | ||
173 | ${OE_QMAKE_PATH_PLUGINS}/*/*.prl \ | ||
174 | ${OE_QMAKE_PATH_PLUGINS}/*/*/*.a \ | ||
175 | ${OE_QMAKE_PATH_PLUGINS}/*/*/*.prl \ | ||
176 | ${OE_QMAKE_PATH_QML}/*/*.a \ | ||
177 | ${OE_QMAKE_PATH_QML}/*/*.prl \ | ||
178 | ${OE_QMAKE_PATH_QML}/*/*/*.a \ | ||
179 | ${OE_QMAKE_PATH_QML}/*/*/*.prl \ | ||
180 | ${OE_QMAKE_PATH_QML}/*/*/*/*.a \ | ||
181 | ${OE_QMAKE_PATH_QML}/*/*/*/*.prl \ | ||
182 | ${OE_QMAKE_PATH_QML}/*/*/*/*/*.a \ | ||
183 | ${OE_QMAKE_PATH_QML}/*/*/*/*/*.prl \ | ||
162 | " | 184 | " |
163 | FILES_${PN}-examples = " \ | 185 | FILES_${PN}-examples = " \ |
164 | ${OE_QMAKE_PATH_EXAMPLES}/* \ | 186 | ${OE_QMAKE_PATH_EXAMPLES}/* \ |
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index bf05cf81..fdaf031f 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -70,6 +70,7 @@ PACKAGECONFIG_RELEASE ?= "release" | |||
70 | # PACKAGECONFIG_OPENSSL ?= "openssl" | 70 | # PACKAGECONFIG_OPENSSL ?= "openssl" |
71 | PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype tests \ | 71 | PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype tests \ |
72 | ${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Os', 'optimize-size ltcg', '', d)} \ | 72 | ${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Os', 'optimize-size ltcg', '', d)} \ |
73 | ${@bb.utils.contains('DISTRO_FEATURES', 'qt5-static', 'static', '', d)} \ | ||
73 | " | 74 | " |
74 | 75 | ||
75 | PACKAGECONFIG ?= " \ | 76 | PACKAGECONFIG ?= " \ |
@@ -84,6 +85,7 @@ PACKAGECONFIG ?= " \ | |||
84 | ${PACKAGECONFIG_DISTRO} \ | 85 | ${PACKAGECONFIG_DISTRO} \ |
85 | " | 86 | " |
86 | 87 | ||
88 | PACKAGECONFIG[static] = "-static,-shared" | ||
87 | PACKAGECONFIG[release] = "-release,-debug" | 89 | PACKAGECONFIG[release] = "-release,-debug" |
88 | PACKAGECONFIG[debug] = "" | 90 | PACKAGECONFIG[debug] = "" |
89 | PACKAGECONFIG[developer] = "-developer-build" | 91 | PACKAGECONFIG[developer] = "-developer-build" |
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb index 69e90570..e6173b4e 100644 --- a/recipes-qt/qt5/qtdeclarative_git.bb +++ b/recipes-qt/qt5/qtdeclarative_git.bb | |||
@@ -14,10 +14,11 @@ LIC_FILES_CHKSUM = " \ | |||
14 | 14 | ||
15 | DEPENDS += "qtbase" | 15 | DEPENDS += "qtbase" |
16 | 16 | ||
17 | PACKAGECONFIG ??= "qtxmlpatterns qml-debug qml-network" | 17 | PACKAGECONFIG ??= "qtxmlpatterns qml-debug qml-network ${@bb.utils.contains('DISTRO_FEATURES', 'qt5-static', 'static', '', d)}" |
18 | PACKAGECONFIG[qtxmlpatterns] = ",,qtxmlpatterns" | 18 | PACKAGECONFIG[qtxmlpatterns] = ",,qtxmlpatterns" |
19 | PACKAGECONFIG[qml-debug] = "-qml-debug,-no-qml-debug" | 19 | PACKAGECONFIG[qml-debug] = "-qml-debug,-no-qml-debug" |
20 | PACKAGECONFIG[qml-network] = "-qml-network, -no-qml-network" | 20 | PACKAGECONFIG[qml-network] = "-qml-network, -no-qml-network" |
21 | PACKAGECONFIG[static] = ",,qtdeclarative-native" | ||
21 | 22 | ||
22 | do_configure_prepend() { | 23 | do_configure_prepend() { |
23 | # disable qtxmlpatterns test if it isn't enabled by PACKAGECONFIG | 24 | # disable qtxmlpatterns test if it isn't enabled by PACKAGECONFIG |
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb index 11ee347e..32ad875c 100644 --- a/recipes-qt/qt5/qtwebengine_git.bb +++ b/recipes-qt/qt5/qtwebengine_git.bb | |||
@@ -73,6 +73,10 @@ inherit qmake5 | |||
73 | inherit gettext | 73 | inherit gettext |
74 | inherit pythonnative | 74 | inherit pythonnative |
75 | inherit perlnative | 75 | inherit perlnative |
76 | inherit distro_features_check | ||
77 | |||
78 | # Static builds of QtWebEngine aren't supported. | ||
79 | CONFLICT_DISTRO_FEATURES = "qt5-static" | ||
76 | 80 | ||
77 | # we don't want gettext.bbclass to append --enable-nls | 81 | # we don't want gettext.bbclass to append --enable-nls |
78 | def gettext_oeconf(d): | 82 | def gettext_oeconf(d): |