diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2020-04-07 19:26:56 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2020-04-07 19:32:08 +0200 |
commit | 02930760c8be7c9d850919cda89469e9c0120d6c (patch) | |
tree | a5ec557fdee02822bda41651361bef3553989653 | |
parent | b8bcf8cb576d072f435a0177375e54424f67d1c9 (diff) | |
download | meta-qt5-02930760c8be7c9d850919cda89469e9c0120d6c.tar.gz |
qtmultimedia: create /usr/lib/plugins/videoeglvideonode referenced by Qt5MultimediaConfig.cmake
* using Qt5MultimediaConfig.cmake fails with error bellow, temorary fix that by
creating empty directory
CMake Error at /OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/cmake/Qt5Multimedia/Qt5MultimediaConfig.cmake:31 (message):
The imported target "Qt5::Multimedia" references the file
"/OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/plugins/videoeglvideonode"
but this file does not exist. Possible reasons include:
* The file was deleted, renamed, or moved to another location.
* An install or uninstall procedure did not complete successfully.
* The installation package was faulty and contained
"/OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/cmake/Qt5Multimedia/Qt5Multimedia_QSGVideoNodeFactory_EGL.cmake"
but not all the files it references.
Call Stack (most recent call first):
/OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/cmake/Qt5Multimedia/Qt5MultimediaConfig.cmake:244 (_qt5_Multimedia_check_file_exists)
/OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/cmake/Qt5Multimedia/Qt5Multimedia_QSGVideoNodeFactory_EGL.cmake:5 (_populate_Multimedia_plugin_properties)
/OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/cmake/Qt5Multimedia/Qt5MultimediaConfig.cmake:253 (include)
CMakeLists.txt:43 (find_package)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | recipes-qt/qt5/qtmultimedia_git.bb | 6 |
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb index 58ad1f53..93e87994 100644 --- a/recipes-qt/qt5/qtmultimedia_git.bb +++ b/recipes-qt/qt5/qtmultimedia_git.bb | |||
@@ -39,3 +39,9 @@ SRC_URI += "\ | |||
39 | LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" | 39 | LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" |
40 | 40 | ||
41 | SRCREV = "7f0503acb042d047682b432e68ed97b1644c3f59" | 41 | SRCREV = "7f0503acb042d047682b432e68ed97b1644c3f59" |
42 | |||
43 | # Temporary work around for Qt5MultimediaConfig.cmake referencing non-existent videoeglvideonode directory | ||
44 | do_install_append() { | ||
45 | install -d ${D}${OE_QMAKE_PATH_PLUGINS}/videoeglvideonode | ||
46 | } | ||
47 | FILES_${PN} += "${OE_QMAKE_PATH_PLUGINS}/videoeglvideonode" | ||