summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-06-05 14:01:48 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-06-05 14:03:20 +0000
commit267a38fddeecb28b269fc86f7024e50dbc47acbe (patch)
tree4034b8d77511194d0b84b7b9125c22ca3c12145e
parent7193a7f1f4f49ba940d5b4cc15a46be2077d0a14 (diff)
downloadmeta-qt5-267a38fddeecb28b269fc86f7024e50dbc47acbe.tar.gz
qtwebengine: fix build with gcc8
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/0003-Fix-build-with-gcc8.patch50
-rw-r--r--recipes-qt/qt5/qtwebengine/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch (renamed from recipes-qt/qt5/qtwebengine/0003-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch (renamed from recipes-qt/qt5/qtwebengine/0004-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0006-chromium-musl-include-fcntl.h-for-loff_t.patch (renamed from recipes-qt/qt5/qtwebengine/0005-chromium-musl-include-fcntl.h-for-loff_t.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch (renamed from recipes-qt/qt5/qtwebengine/0006-chromium-musl-use-off64_t-instead-of-the-internal-__.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0008-chromium-musl-linux-glibc-make-the-distinction.patch (renamed from recipes-qt/qt5/qtwebengine/0007-chromium-musl-linux-glibc-make-the-distinction.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch (renamed from recipes-qt/qt5/qtwebengine/0008-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch (renamed from recipes-qt/qt5/qtwebengine/0009-chromium-musl-Use-correct-member-name-__si_fields-fr.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch (renamed from recipes-qt/qt5/qtwebengine/0010-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch (renamed from recipes-qt/qt5/qtwebengine/0011-chromium-musl-Do-not-define-__sbrk-on-musl.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0013-chromium-musl-Adjust-default-pthread-stack-size.patch (renamed from recipes-qt/qt5/qtwebengine/0012-chromium-musl-Adjust-default-pthread-stack-size.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch (renamed from recipes-qt/qt5/qtwebengine/0013-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch (renamed from recipes-qt/qt5/qtwebengine/0014-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb27
14 files changed, 76 insertions, 25 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0003-Fix-build-with-gcc8.patch b/recipes-qt/qt5/qtwebengine/0003-Fix-build-with-gcc8.patch
new file mode 100644
index 00000000..10c81e9e
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0003-Fix-build-with-gcc8.patch
@@ -0,0 +1,50 @@
1From 334c96ea89c49d559f955182c9a30c62919622ca Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Tue, 5 Jun 2018 13:58:16 +0000
4Subject: [PATCH] Fix build with gcc8
5
6---
7 chromium/mojo/public/c/system/buffer.h | 2 +-
8 chromium/mojo/public/c/system/data_pipe.h | 2 +-
9 chromium/mojo/public/c/system/message_pipe.h | 2 +-
10 3 files changed, 3 insertions(+), 3 deletions(-)
11
12diff --git a/chromium/mojo/public/c/system/buffer.h b/chromium/mojo/public/c/system/buffer.h
13index 09f6d285f3..e516a09e49 100644
14--- a/chromium/mojo/public/c/system/buffer.h
15+++ b/chromium/mojo/public/c/system/buffer.h
16@@ -35,7 +35,7 @@ const MojoCreateSharedBufferOptionsFlags
17 ((MojoCreateSharedBufferOptionsFlags)0)
18 #endif
19
20-MOJO_STATIC_ASSERT(MOJO_ALIGNOF(int64_t) == 8, "int64_t has weird alignment");
21+MOJO_STATIC_ASSERT(MOJO_ALIGNOF(int64_t) == 4 || MOJO_ALIGNOF(int64_t) == 8, "int64_t has weird alignment");
22 struct MOJO_ALIGNAS(8) MojoCreateSharedBufferOptions {
23 uint32_t struct_size;
24 MojoCreateSharedBufferOptionsFlags flags;
25diff --git a/chromium/mojo/public/c/system/data_pipe.h b/chromium/mojo/public/c/system/data_pipe.h
26index 62adbea1ea..76225858ba 100644
27--- a/chromium/mojo/public/c/system/data_pipe.h
28+++ b/chromium/mojo/public/c/system/data_pipe.h
29@@ -46,7 +46,7 @@ const MojoCreateDataPipeOptionsFlags MOJO_CREATE_DATA_PIPE_OPTIONS_FLAG_NONE =
30 ((MojoCreateDataPipeOptionsFlags)0)
31 #endif
32
33-MOJO_STATIC_ASSERT(MOJO_ALIGNOF(int64_t) == 8, "int64_t has weird alignment");
34+MOJO_STATIC_ASSERT(MOJO_ALIGNOF(int64_t) == 4 || MOJO_ALIGNOF(int64_t) == 8, "int64_t has weird alignment");
35 struct MOJO_ALIGNAS(8) MojoCreateDataPipeOptions {
36 MOJO_ALIGNAS(4) uint32_t struct_size;
37 MOJO_ALIGNAS(4) MojoCreateDataPipeOptionsFlags flags;
38diff --git a/chromium/mojo/public/c/system/message_pipe.h b/chromium/mojo/public/c/system/message_pipe.h
39index f0f69d1025..364a02971e 100644
40--- a/chromium/mojo/public/c/system/message_pipe.h
41+++ b/chromium/mojo/public/c/system/message_pipe.h
42@@ -44,7 +44,7 @@ const MojoCreateMessagePipeOptionsFlags
43 ((MojoCreateMessagePipeOptionsFlags)0)
44 #endif
45
46-MOJO_STATIC_ASSERT(MOJO_ALIGNOF(int64_t) == 8, "int64_t has weird alignment");
47+MOJO_STATIC_ASSERT(MOJO_ALIGNOF(int64_t) == 4 || MOJO_ALIGNOF(int64_t) == 8, "int64_t has weird alignment");
48 struct MOJO_ALIGNAS(8) MojoCreateMessagePipeOptions {
49 uint32_t struct_size;
50 MojoCreateMessagePipeOptionsFlags flags;
diff --git a/recipes-qt/qt5/qtwebengine/0003-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch b/recipes-qt/qt5/qtwebengine/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
index 96dee6a5..678e5775 100644
--- a/recipes-qt/qt5/qtwebengine/0003-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
+++ b/recipes-qt/qt5/qtwebengine/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
@@ -1,4 +1,4 @@
1From b0f4e5412e2cd7eecd63e61c2903d27bad1e438f Mon Sep 17 00:00:00 2001 1From e6e9d77a7a1c174c09214b89b2e1ac034099ea67 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 14:01:12 -0700 3Date: Fri, 7 Jul 2017 14:01:12 -0700
4Subject: [PATCH] chromium: musl: sandbox: Define TEMP_FAILURE_RETRY if not 4Subject: [PATCH] chromium: musl: sandbox: Define TEMP_FAILURE_RETRY if not
diff --git a/recipes-qt/qt5/qtwebengine/0004-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch b/recipes-qt/qt5/qtwebengine/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
index 12cdad81..f9163b4f 100644
--- a/recipes-qt/qt5/qtwebengine/0004-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
+++ b/recipes-qt/qt5/qtwebengine/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
@@ -1,4 +1,4 @@
1From e77a7338d6c25babab860fd1456047ec90297fe9 Mon Sep 17 00:00:00 2001 1From 68356e04310ab5a2fb7869bacc899a718d448033 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 14:09:06 -0700 3Date: Fri, 7 Jul 2017 14:09:06 -0700
4Subject: [PATCH] chromium: musl: Avoid mallinfo() APIs on non-glibc/linux 4Subject: [PATCH] chromium: musl: Avoid mallinfo() APIs on non-glibc/linux
diff --git a/recipes-qt/qt5/qtwebengine/0005-chromium-musl-include-fcntl.h-for-loff_t.patch b/recipes-qt/qt5/qtwebengine/0006-chromium-musl-include-fcntl.h-for-loff_t.patch
index d30693b5..0e3c7612 100644
--- a/recipes-qt/qt5/qtwebengine/0005-chromium-musl-include-fcntl.h-for-loff_t.patch
+++ b/recipes-qt/qt5/qtwebengine/0006-chromium-musl-include-fcntl.h-for-loff_t.patch
@@ -1,4 +1,4 @@
1From 570159b9334b8eb242b597846cd2cfa82164babf Mon Sep 17 00:00:00 2001 1From aca69707d74a9286fecf1017c59c8dea91bd7f14 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 14:37:49 -0700 3Date: Fri, 7 Jul 2017 14:37:49 -0700
4Subject: [PATCH] chromium: musl: include fcntl.h for loff_t 4Subject: [PATCH] chromium: musl: include fcntl.h for loff_t
diff --git a/recipes-qt/qt5/qtwebengine/0006-chromium-musl-use-off64_t-instead-of-the-internal-__.patch b/recipes-qt/qt5/qtwebengine/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
index 652d782c..8404ad67 100644
--- a/recipes-qt/qt5/qtwebengine/0006-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
+++ b/recipes-qt/qt5/qtwebengine/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
@@ -1,4 +1,4 @@
1From 9e7821ff3f65bc6b5b541800c4911c28121e25d4 Mon Sep 17 00:00:00 2001 1From bcbb7edd4e5acdc775a4cfbceafd9bd5a4bbbae5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 14:38:37 -0700 3Date: Fri, 7 Jul 2017 14:38:37 -0700
4Subject: [PATCH] chromium: musl: use off64_t instead of the internal __off64_t 4Subject: [PATCH] chromium: musl: use off64_t instead of the internal __off64_t
diff --git a/recipes-qt/qt5/qtwebengine/0007-chromium-musl-linux-glibc-make-the-distinction.patch b/recipes-qt/qt5/qtwebengine/0008-chromium-musl-linux-glibc-make-the-distinction.patch
index 328481e4..70e23cc8 100644
--- a/recipes-qt/qt5/qtwebengine/0007-chromium-musl-linux-glibc-make-the-distinction.patch
+++ b/recipes-qt/qt5/qtwebengine/0008-chromium-musl-linux-glibc-make-the-distinction.patch
@@ -1,4 +1,4 @@
1From 9e83cb6ba980a66563cc4c5b5c863180f0b538aa Mon Sep 17 00:00:00 2001 1From ce13970c1b2d397377461e2b92be541f6778dd79 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 14:54:38 -0700 3Date: Fri, 7 Jul 2017 14:54:38 -0700
4Subject: [PATCH] chromium: musl: linux != glibc, make the distinction 4Subject: [PATCH] chromium: musl: linux != glibc, make the distinction
diff --git a/recipes-qt/qt5/qtwebengine/0008-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch b/recipes-qt/qt5/qtwebengine/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
index c7309275..b4a67360 100644
--- a/recipes-qt/qt5/qtwebengine/0008-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
+++ b/recipes-qt/qt5/qtwebengine/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
@@ -1,4 +1,4 @@
1From 6984ed77603d2c20f7cfdc3aa25d79bafaa475c0 Mon Sep 17 00:00:00 2001 1From cc0cf540da630b6646601b20c3b55a828ba337f7 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 15:09:02 -0700 3Date: Fri, 7 Jul 2017 15:09:02 -0700
4Subject: [PATCH] chromium: musl: allocator: Do not include glibc_weak_symbols 4Subject: [PATCH] chromium: musl: allocator: Do not include glibc_weak_symbols
diff --git a/recipes-qt/qt5/qtwebengine/0009-chromium-musl-Use-correct-member-name-__si_fields-fr.patch b/recipes-qt/qt5/qtwebengine/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
index f4eab301..52caf6c4 100644
--- a/recipes-qt/qt5/qtwebengine/0009-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
+++ b/recipes-qt/qt5/qtwebengine/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
@@ -1,4 +1,4 @@
1From 7f6bef2fe015663d8218921835166f54266f126a Mon Sep 17 00:00:00 2001 1From 3c5e5f6dc8f5853838dec1ef198caa06a651d5e0 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 15:12:39 -0700 3Date: Fri, 7 Jul 2017 15:12:39 -0700
4Subject: [PATCH] chromium: musl: Use correct member name __si_fields from 4Subject: [PATCH] chromium: musl: Use correct member name __si_fields from
diff --git a/recipes-qt/qt5/qtwebengine/0010-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch b/recipes-qt/qt5/qtwebengine/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
index 3cb25179..de690873 100644
--- a/recipes-qt/qt5/qtwebengine/0010-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
+++ b/recipes-qt/qt5/qtwebengine/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
@@ -1,4 +1,4 @@
1From 1582b4305705d66e8f4c4d27c2edf5d4842c8a69 Mon Sep 17 00:00:00 2001 1From c2a5b9616eff83826852b5b9d0a32ddd93764c6a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 15:27:50 -0700 3Date: Fri, 7 Jul 2017 15:27:50 -0700
4Subject: [PATCH] chromium: musl: Define res_ninit and res_nclose for non-glibc 4Subject: [PATCH] chromium: musl: Define res_ninit and res_nclose for non-glibc
diff --git a/recipes-qt/qt5/qtwebengine/0011-chromium-musl-Do-not-define-__sbrk-on-musl.patch b/recipes-qt/qt5/qtwebengine/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch
index 9bd97565..ab452716 100644
--- a/recipes-qt/qt5/qtwebengine/0011-chromium-musl-Do-not-define-__sbrk-on-musl.patch
+++ b/recipes-qt/qt5/qtwebengine/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch
@@ -1,4 +1,4 @@
1From 291a34f1252619a654c0bdc7bd779890e9bd3b4b Mon Sep 17 00:00:00 2001 1From 0f06eb79e93f756719049223b790e3feb3844642 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 15:39:57 -0700 3Date: Fri, 7 Jul 2017 15:39:57 -0700
4Subject: [PATCH] chromium: musl: Do not define __sbrk on musl 4Subject: [PATCH] chromium: musl: Do not define __sbrk on musl
diff --git a/recipes-qt/qt5/qtwebengine/0012-chromium-musl-Adjust-default-pthread-stack-size.patch b/recipes-qt/qt5/qtwebengine/0013-chromium-musl-Adjust-default-pthread-stack-size.patch
index 57501f5f..5144fbb6 100644
--- a/recipes-qt/qt5/qtwebengine/0012-chromium-musl-Adjust-default-pthread-stack-size.patch
+++ b/recipes-qt/qt5/qtwebengine/0013-chromium-musl-Adjust-default-pthread-stack-size.patch
@@ -1,4 +1,4 @@
1From 5ca95d5c90e867fb5e69414d4371be6cc7436f1e Mon Sep 17 00:00:00 2001 1From 544a41a83d4a17a998e72296429b442fd103f4f3 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 16:41:23 -0700 3Date: Fri, 7 Jul 2017 16:41:23 -0700
4Subject: [PATCH] chromium: musl: Adjust default pthread stack size 4Subject: [PATCH] chromium: musl: Adjust default pthread stack size
diff --git a/recipes-qt/qt5/qtwebengine/0013-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch b/recipes-qt/qt5/qtwebengine/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch
index 00793ef8..7c63e193 100644
--- a/recipes-qt/qt5/qtwebengine/0013-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch
+++ b/recipes-qt/qt5/qtwebengine/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch
@@ -1,4 +1,4 @@
1From 1633367ce21f63a747b1523867a1bf431098f223 Mon Sep 17 00:00:00 2001 1From 85d7a5e3cd7db85b5a9305f35ba4c1a76c96a696 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 17:15:34 -0700 3Date: Fri, 7 Jul 2017 17:15:34 -0700
4Subject: [PATCH] chromium: musl: include asm-generic/ioctl.h for TCGETS2 4Subject: [PATCH] chromium: musl: include asm-generic/ioctl.h for TCGETS2
diff --git a/recipes-qt/qt5/qtwebengine/0014-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch b/recipes-qt/qt5/qtwebengine/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch
index 1d037fde..b967f1d1 100644
--- a/recipes-qt/qt5/qtwebengine/0014-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch
+++ b/recipes-qt/qt5/qtwebengine/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch
@@ -1,4 +1,4 @@
1From 597ec448bce31e3cb9fc000a516c799a85eb6ded Mon Sep 17 00:00:00 2001 1From 0a0d0244d8282c93dbe32f35ba390f239ff6e137 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 8 Jul 2017 09:08:23 -0700 3Date: Sat, 8 Jul 2017 09:08:23 -0700
4Subject: [PATCH] chromium: musl: tcmalloc: Use off64_t insread of __off64_t 4Subject: [PATCH] chromium: musl: tcmalloc: Use off64_t insread of __off64_t
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 24869f84..3cd549a9 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -137,25 +137,26 @@ SRC_URI_append_libc-musl = "\
137" 137"
138 138
139# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/65-based 139# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/65-based
140# 65-based.meta-qt5.3 140# 65-based.meta-qt5.4
141SRC_URI += " \ 141SRC_URI += " \
142 file://0001-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \ 142 file://0001-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \
143 file://0002-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \ 143 file://0002-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
144 file://0003-Fix-build-with-gcc8.patch;patchdir=src/3rdparty \
144" 145"
145 146
146SRC_URI_append_libc-musl = "\ 147SRC_URI_append_libc-musl = "\
147 file://0003-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \ 148 file://0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
148 file://0004-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \ 149 file://0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
149 file://0005-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \ 150 file://0006-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
150 file://0006-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \ 151 file://0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
151 file://0007-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \ 152 file://0008-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
152 file://0008-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \ 153 file://0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
153 file://0009-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \ 154 file://0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
154 file://0010-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \ 155 file://0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
155 file://0011-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \ 156 file://0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
156 file://0012-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \ 157 file://0013-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
157 file://0013-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \ 158 file://0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \
158 file://0014-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \ 159 file://0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
159" 160"
160 161
161SRCREV_qtwebengine = "28e0320235d33f00c6c141a549dc0553ee0043a5" 162SRCREV_qtwebengine = "28e0320235d33f00c6c141a549dc0553ee0043a5"